Announcement

Collapse
No announcement yet.

Error downloading board in the arduino IDE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error downloading board in the arduino IDE

    Hello all,

    I'm awaiting a response from the 4d team and figured I'd post my issue here, as well.
    I've just received my 4duino and am very excited to get started, however I can't seem to download the board in the arduino ide. I've followed the quick start guide as closely as I can, but when I look for the board in board manager, the ide returns:
    Error downloading http://www.4dsystems.com.au/download...ems_index.json

    Anyone else having this problem?
    Thanks,
    Sean

  • #2
    Hello Sean

    The link is http://www.4dsystems.com.au/download...ems_index.json
    Code:
    http://www.4dsystems.com.au/downloads/4Duino/package_4dsystems_index.json
    4Duino with a capital D, you had lower case.

    Please try that. I took your link and changed the D to capital, and the download was successful.

    Kind Regards
    James

    Comment


    • #3
      That was it. In the quick start guide, it is listed with a lower case 'd'.
      Thank you!!!

      Comment


      • #4
        Excellent.
        Enjoy the 4Duino!
        I will get our IT people to make a duplicate on the server so other people don't experience this. Thanks for informing me.
        James

        Comment


        • #5
          Just to follow this up, our server has been modified to allow both 4duino and 4Duino path links now.
          Either should work.

          Can you please confirm what "Quick Start Guide" you are referring to which has this lower case link? Just so I am 100% sure so I can investigate further.

          Thanks
          James

          Comment


          • #6
            Hi,
            Sorry for the delayed response. The guide that I was following was at the following address:
            http://www.4duino.com/downloads/docs...tart-Guide.pdf

            Thanks for your quick response to this issue.

            Sean

            Comment


            • #7
              I'm having a similar problem loading the the 4Duino using the Arduino's IDE Board Manager. Everything loaded just fine on my Dell laptop. However, on my tower I keep getting a download error when attempting to download either the 1.6.10 or 1.6.7 hardware profiles. I'm using the 1.6.7 version of the Arduino IDE. Any thoughts?

              Comment


              • #8
                Hello rfterry,

                Using Arduino IDE 1.6.7 means you should only download the board for 1.6.7, as 1.6.10 had some changes and it likely will not work.

                Unsure why you are having download issues, but maybe you need to clear out the IDE's files for the boards and let it start again. Close the Arduino IDE.

                Go to C:\Users\[your name]\AppData\Local\Arduino15\staging\packages\ and in there you will find likely a file or two starting with '4dsystems'. Delete them.
                Then go to C:\Users\[your name]\AppData\Local\Arduino15\packages\ and delete the folder called '4D Systems'

                Open the Arduino IDE, and download the 1.6.7 board package for the 4Duino, and hopefully you will be OK.

                Reply back with how you got on.

                Regards
                James

                Comment


                • #9
                  Please, can you help me out here!

                  I used the Wifi temperature code, it uploaded fine, and connected to wifi successfully bur the issue is that it tell me received: error after setup end

                  Comment


                  • #10
                    Hi

                    Welcome to the forum,

                    Could you check this line to see if it 's the same as

                    hndl = Display.file_LoadImageControl("WiFi_T~1.dat", "WiFi_T~1.gci", 1);

                    and also check that WiFi_T~1.dat and WiFi_T~1.gci exist on the SD card.

                    I hope this helps

                    Best regards

                    Paul

                    Comment


                    • #11
                      Hi PAUL,

                      I had commented out all display serial so as to concentrate on wifi and thingspeak alone.
                      setup begin
                      FW Version:
                      busy p...
                      AT+GMR
                      busy p...
                      to station + softap ok
                      Join AP success
                      IP: +CIFSR:APIP,"192.168.4.1"
                      +CIFSR:APMAC,"5e:cf:7f:1c:c0:6a"
                      +CIFSR:STAIP,"192.168.43.170"
                      +CIFSR:STAMAC,"5c:cf:7f:1c:c0:6a"
                      multiple ok
                      setup end
                      RECEIVED: Error Connecting

                      The last part of the message is my problem.

                      Thanks fr the help Paul.

                      Cheers!

                      Comment


                      • #12
                        Kayvins,

                        Please get a writeAPIKey from www.thingspeak.com. Or use the one in the demo code from www.4duino.com
                        Attached is the screen capture when the 4Duino is communicating correctly to thingspeak.
                        Make sure the IP address for thingspeak is 184.106.153.149. you can test it by pasting this IP address
                        to your browser and you should access the thingspeak website.

                        best regards, Click image for larger version

Name:	WifiTempThingspeak.PNG
Views:	1
Size:	42.9 KB
ID:	57966

                        Comment


                        • #13
                          Hi Noel,
                          I appreciate your help here. I have tried using the write API key from 4duino demo, and it is giving me the same story. Do you think the power might be the problem, cos I have been powering the 4duino through my laptop. I can't find that pin type 5 volt supply in my area.

                          Once more I wanna say thank you for helping out.

                          Cheers!

                          Comment


                          • #14
                            Kayvins,

                            Using your Desktop PC or Laptop with Internet Access, please paste this IP address: 184.106.153.149
                            to your Web Browser. You should access www.thingspeak.com. If you cannot access the Website,
                            please check the Firewall settings of your Wireless Router. Check if it is configured to block
                            some sites or a range of IP Addresses.

                            Best regards,

                            Comment


                            • #15
                              Noel,
                              Thank you very much. It eventually worked but noticed I can't check my reading in the serial monitor as well as stream the data to thingspeak maybe I'll have to use the display. All the same, I was able to send up to five data for five fields on my channel. I HOPE THE RESULTS WON'T BE AFFECTED IN ANYWAY?

                              Once again, I say thank you.

                              Comment

                              Working...
                              X