Announcement

Collapse
No announcement yet.

Upload problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hi,

    Sorry to hear you are still having a problem.

    The 4Duino is not the problem here, it is a very unusual communication problem.

    Can you confirm that both 4Duino's still work on the Arduino IDE running on the Apple platform.

    If not, it is possible the Atmega32u4's bootloader has been corrupted which may have happened during the attempts using Virtual Box.

    It is possible to restore the bootloader if you have an ICSP programmer or a spare Arduino that you can use as an ICSP programmer.

    Can you please let us know if both 4Duino's work using the Apple and Arduino IDE.


    Best regards

    Comment


    • #17
      yes Apple both work ok aliad Leonardo board, but after use, upload on the Apple - Windows DEVICE MANAGE canot find device :-(

      Comment


      • #18
        my question - its possible working wit 4duino on the Apple?! How i can upload graphics?! ..
        i have "Starter Kit" .. with uUSB-PA5-II (Programming Adaptor)
        i have more Arduino MEGA boards

        Comment


        • #19
          Hi,

          Sorry to keep asking questions,
          Have you successfully uploaded a sketch to both 4Duino's using the Arduino IDE on the apple?
          Even if it is just the blink example using leonardo as the board.

          We will still try to get this working in windows and workshop4, I am trying to find out if the bootloader is good on both 4Duino's.

          Best regards

          Paul

          Comment


          • #20
            Have you successfully uploaded a sketch to both 4Duino's using the Arduino IDE on the apple?
            YES

            Even if it is just the blink example using leonardo as the board.
            YES

            Sample "blink" program, next BLANK code .. successfully

            Comment


            • #21
              Now no one board on the Windows not found :-( .. only on the Apple alias Leonardo board.

              Comment


              • #22
                Hi,

                When you load a sketch into the 4Duino when you have the board selected as a Leonardo, the board will identify as a Leonardo from that point, as the sketch determines the PID/VID combination which identifies what the board is. So if you loaded the sketch on your Mac as a Leonardo, then the PC will see it as a Leonardo when you plug it in there.
                When you load a sketch, the 4Duino board changes from Run Mode into Bootloader Mode, each mode uses a different serial port in device manager. Run Mode gets its VID/PID from the sketch, Bootloader Mode gets its VID/PID from the bootloader. Only Windows uses the Driver, Mac does not need one, and does not care as much about VID/PID like Windows does.

                We need to get the two 4Duino's recognised as 4Duino.

                On your Apple and Arduino IDE, can you please follow this step.

                Add the following JSON URL into the Preferences window of Arduino IDE, under the Additional

                Boards Manager URLs field:

                Code:
                http://www.4dsystems.com.au/downloads/4Duino/package_4dsystems_index.json
                Then choose 4Duino as a board.

                Then upload the blink example.
                Your boards should then be identifying as 4Duinos now, since you loaded the sketch with 4Duino board being selected.
                Please confirm this is the case.

                Best regards

                Paul

                Comment


                • #23
                  Windows found, done.
                  (Windows) Arduino IDE again not upload..

                  Workshop 4 write:

                  Comment


                  • #24
                    Windows found, done.
                    (Windows) Arduino IDE again not upload..

                    Workshop 4 write: Click image for larger version

Name:	aa.jpeg
Views:	1
Size:	1.23 MB
ID:	57509

                    Comment


                    • #25
                      Hi,

                      Can we now try the same thing in the Arduino IDE on your windows environment

                      On your WINDOWS and Arduino IDE, can you please follow this step.

                      Add the following JSON URL into the Preferences window of Arduino IDE, under the Additional

                      Boards Manager URLs field:

                      Code:

                      http://www.4dsystems.com.au/download...ems_index.json
                      Then choose 4Duino as a board.


                      Best regards

                      Paul

                      Comment


                      • #26
                        This step I have done. Tools / Get Board Info work. But I click UPLOAD, after compiling DEVICE MANAGER unplugg 4duino .. 3sec and again is the board connected, Arduino IDE "Uploading.." .. but NOT UPLOAD.

                        Comment


                        • #27
                          Click image for larger version

Name:	ss.jpeg
Views:	1
Size:	967.0 KB
ID:	57514 ...............

                          Comment


                          • #28
                            Hi,

                            Do you have access to a windows PC or is it just the Apple and Virtual Box?

                            We really need to be using a windows PC for Workshop 4. There are a lot of unknowns within Virtual Box. My attempt here with Virtual Box was unsuccessful.

                            Best regards

                            Paul

                            Comment


                            • #29
                              have you tried dual boot on mac via BOOTCAMP to have windows working in the mac hardware directly instead of by virtualization?

                              Comment


                              • #30
                                huuuraaa .. I woork!
                                a. virtual machhine is ****, no work
                                b. my second win notebook have a port problem
                                c. my 3. book wit Win7 work! 2 weeks .. but today I live! :-)

                                Thanks.
                                Last edited by James_4DSystems; 30th April 2017, 08:48 AM. Reason: No swearing please

                                Comment

                                Working...
                                X