Announcement

Collapse
No announcement yet.

problem sending image

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem sending image

    Hi folks, i've been trying to send an image file (jpg/bmp/gif) to my uOLED-160-G1 screen using the FAT controller software but I keep getting error messages like this:

    Write of 10324 bytes failed after 0 bytes
    with System Error 'The operation completed successfully'
    • The number of bytes varies depending on the image i'm trying to send.
    • The first few rows of the image prints to the screen then stops however the full image is shown on the simulated screen on the software.
    • There is no data in the "report" screen and all subsequent commands fail until I close and re-open the port. If I close and re-open the port immediatly after sending an image the report screen with then display the following:
    Image 50.014 [49 00 00 43 4D 10 FF FF FF FF E6 9C AD 16 94 72 B5 96 DE DB FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF...]

    I'm I missing something obvious?

  • #2


    I don't think so, you have just found a limitation of the MB5 that FAT Controller is 'hitting'.

    The MB5 driver has a limited buffer and it chokes when you send a large image via FAT Controller. In a real program you wouldn't do it that way, so you wouldn't encounter that problem.
    Mark

    Comment


    • #3


      great, thanks for the informaiton.

      Comment

      Working...
      X