Announcement

Collapse
No announcement yet.

Cannot sync camera TTl with my PIC

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot sync camera TTl with my PIC

    I'm having a problem in order to sync my pic18f46j50 with the camera via TTL. I'm not reciving an answer at all, I send it 60 times the sequence but still have no answer, I really dont know what can be the problem of my code.. I've also tried all the baud accepted and still nothing happend.

    PD. Using USART2, RA0 as TX and RA1 as RX. I connect TX from camera to RX of my pic and viceversa.

    Hope u can figure out what's missing in my code. Thanks.

    [HTML] PPSUnLock();
    iPPSOutput(OUT_PIN_PPS_RP1, OUT_FN_PPS_TX2CK2); //Tx = RA1
    iPPSInput(IN_FN_PPS_RX2DT2, IN_PIN_PPS_RP0); //RX = RA0
    PPSLock();
    TRISA=1;
    Close2USART();
    Open2USART( USART_TX_INT_OFF & USART_RX_INT_OFF & USART_ASYNCH_MODE &
    USART_EIGHT_BIT & USART_CONT_RX & USART_BRGH_HIGH, 8);//115200 baud*/

    while(1){
    i = 0;
    while(cont

  • #2


    I can't really tell much from your code.

    It's not obvious what baud rate you are really using, nor is there any hint that what you are sending to the camera is actually the correct sync command.

    Does the camera work with the uCam demo software?

    Can you connect a serial port up to the Pic TX to monitor what is really being sent? (Eg, if you have a 4D programming cable, connect gnd to gnd and RX of the cable to TX of the PIC, then sue the 4D terminal program to see what is really being sent)
    Mark

    Comment


    • #3


      Thanks for the fast answer.
      I can't connect anything, I checked the TX with a oscilloscope in order to check if i was sending properly. It's a college proyect I'm using the tools provided.
      Guess I'll try harder.

      Thanks again.

      Comment

      Working...
      X