Announcement

Collapse
No announcement yet.

Arduino MKR1000 Serial signal level to diablo16 display

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Arduino MKR1000 Serial signal level to diablo16 display

    All,

    I'm figuring out why my communication to the MKR1000 board isn't working as it should be. Anyone who had this problem before?

    I've a program that works fine with a Uno and I changed everything that's needed to make the serial communication to the Display (E.g. Serial1 different RX, TX compared to the uno board) but didn't succeed in getting the com setup. I even wandered around on this forum but couldn't find the proper solution.

    Is this maybe due to the fact that the board is only sending data with a signal of max. 3.3V comparing to the 5V of the regular arduino boards?

    Thanks

  • #2
    Hello,

    Welcome to the forum,

    Our displays run on 3v3 logic and are 5v tolerant so this will not be the issue. You are right to use Serial1 on GPIO13 & GPIO14 so this should work for you.

    You should also have a reset routine to reset the display like you would on the UNO. Can you tell me what programming environment you are using.

    Best regards

    Paul

    Comment


    • #3
      I just found out that the gen4PA shied was causing problems as this has also a usb to uart communication to program the display.

      This interfere with the MKR1000 USB to serial on-board chip and for the UNO board it doesn't seem to interfere.

      When I used the normal flatcable to serial shield everything was more or less working

      Maybe a heads up for other members in the future.

      Comment

      Working...
      X