Announcement

Collapse
No announcement yet.

slow, accelerate display

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • slow, accelerate display

    Hello @all,
    my system:
    Beaglebone Black, Debian 9.5 LXQT (with graphical desktop)
    gen4-4DCAPE-50CT-CLB
    no more capes

    In the file uEnv.txt I disabled HDMI.
    ###Disable auto loading of virtual capes (emmc/video/wireless/adc)
    #disable_uboot_overlay_emmc=1
    disable_uboot_overlay_video=1
    disable_uboot_overlay_audio=1

    #disable_uboot_overlay_wireless=1
    #disable_uboot_overlay_adc=1

    The display has been correctly recognized and everything is displayed.
    A web server is running on the Beagleboard.
    The call of this WebApp by an external device (PC or Smartphone) is super fast.
    It takes about 1 second to open a page.
    However, if I call the page localhost:8082 with the onboard browser Chromium, everything is displayed very slowly. The page call takes about 12 seconds.
    How can I speed this up ?
    What is the problem ?
    The memory of the Beagle is already 96% occupied by the operating system.
    Can I reduce the FPS rate ?

    Thank you very much for your support.

    kind regards
    Starts
    2nd November 2018
    Ends
    3rd November 2018
    Location
    Germany

  • #2
    Hi,

    Welcome to the forum.

    Unfortunately, getting Chromium browser to run faster on BBB is difficult since BBB is a single core device with limited ram.

    Additional information is discussed on this forum thread - https://forum.digikey.com/t/chromium...ch-on-bbb/1787. Note that there is a suggestion raised on the thread. You might need it as an alternative.

    Hope this will help.

    Best regards,
    Vince_4D

    Comment


    • #3
      Hi,
      thank you very much for this note.
      I will try it on Monday.
      But I don't think the Midori Browser is that much faster.
      Can I improve the whole thing by lowering the frame rate ? 10Hz or 5Hz would surely be enough.

      best regards

      Comment


      • #4
        Hi,

        I tested the Midori browser as stated in the forum thread and verified that it is much faster than the Chromium.

        As to your question, sorry to say that we could only give you best support for inquiries regarding 4DCAPES and other 4D products.
        If I may suggest, try raising your inquiry to BeagleBone forums. Surely, they could offer you better support than us with regards to BeagleBone software and hardware.

        But afaik, the frame rate is crucial in the responsiveness of the browser. Setting it to lower frame rate may cause a poor response.

        Best regards,
        Vince_4D

        Comment


        • #5
          Hi,

          The Midori Browser is really very fast. But scrolling with the touch panel of the display doesn't work correctly and the display in fullscreen mode doesn't show everything correctly. I didn't have these problems with Chromium.

          I also posted the problem in a Beagleboard forum.

          Next I will try to upgrade to Debian 9.5 IOT (without graphical).
          Install XORG and either firefox or Chromium and see what happens.

          Comment


          • #6
            Hi,

            I verified your observation upon using Midori in Debian 9.5 2018-10-07 4GB SD LXQT image.

            Next I will try to upgrade to Debian 9.5 IOT (without graphical).
            Install XORG and either firefox or Chromium and see what happens.
            Looking forward to your findings and hopefully, you will achieve what you're looking for.

            Best regards,
            Vince_4D

            Comment


            • #7
              I am back :-)
              I have tried the following:
              Installed:
              Debian 9.5 iot (without lxqt)
              xserver_xorg_video_fbdev
              x11_xserver_utils
              lightdm

              As a browser (only these browsers were fast and showed everything neatly)
              midori
              qupzilla
              xombrero

              firefox-esr (crashes at startup)
              chromium-browser (cannot be installed)

              I am satisfied with the display of my HTML page but I can't scroll properly. It only works if you are on the scrollbar with the pointer.
              How can I change this ? Xsession ?

              Alternative:
              How can I make the scrollbar wider ?

              best regards


              Comment


              • #8
                It only works if you are on the scrollbar with the pointer.
                Correct me if I'm wrong, do want the scrolling of the webpage same as how smartphones do?

                If so, sorry to say but it's beyond our expertise. I would like to suggest reaching the BeagleBone support to get precise information with regards to this matter.

                Best regards,
                Vince_4D

                Comment


                • #9
                  Hello, there,

                  that's exactly what I want.
                  I will ask again in a Beagleboard forum.

                  thank you

                  Comment

                  Working...
                  X