Announcement

Collapse
No announcement yet.

FAT16runprog and uSD not running 4xe file

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • FAT16runprog and uSD not running 4xe file

    Morning, 

    Doing some more playing with the uSD card, I copied everything from the :  "/resources/copy to usd/ " folder to my uSD card, and ran the some of the samples to test the audio. no problems.  I then tried to run the FAT16runprog.4dg program, this loads into flash and runs no problems.  The text reports that 16 4xe files are present however pressing any of the icons reports: " Fault NAME.4XE" from the code this would suggest that there is no file: if(file_exists(Name) etc...

    so...  it counts the files at the start of the code using the file_count function, but fails the file_exists funtion

    Card was "complete" formatted in Vista as FAT...

    Thoughts?

    Thanks

    Andy
    MicroLec Industries P/L
    www.intelligym.com.au

  • #2


    It looks like there is a bug in the FAT16 run functions file_Exec and file_Run.

    The demo application runs on my display but none of my own programs.

    I posted it here http://4d.websitetoolbox.com/post?id=3382124 but also PmmC 1.08 doesn't solve this problem. The program I want to start as a funtcion via file_exec is about 4500bytes long and opens it own image lists and Fat16 files. Running thos will cause a reset of the display. Maybe that only small programs can run that way but ther is no info in the documentation. 

    Comment


    • #3


      I haven't tried with pmmc 1.07 yet, I'll give that a crack and see how that goes. perhaps it is a recent bug?

      Anyways it would be nice to have major system components run from different executables from a main "menu" system. 

      Will post results when I have time



      Andy
      MicroLec Industries P/L
      www.intelligym.com.au

      Comment


      • #4


        When will be a new Pmmc available without that bug?

        Comment

        Working...
        X