No announcement yet.

Com port error w/ DISP application

  • Filter
  • Time
  • Show
Clear All
new posts

  • Com port error w/ DISP application


    I was trying to modify the fonts on my uOLED-128-G1 with the DISP application. When I try to load from or save to the display, I get a "Com Port Error". I've used both PCCM tool, and the FATController with the same screen, USB interface, and laptop and they work perfectly. It definetely seems to be the DISP program. I've read the user's manual for the software, but I didn't see anything in there that would help me. Does anybody have any thoughts? Thanks in advance for the time.

    Take care,

  • #2

    You haven't said which version of DISP you are using or the version of the PmmC.

    Anyway, I have tried with a couple of versions of DISP and cannot reproduce the problem.

    Are you sure you are using DISP with an SGC PmmC?

    You will get a com port error if you try to use DISP with the original serial PmmC, or a 4DGL PmmC.


    • #3

      Okay, I didn't realize that DISP wouldn't work with the serial .pccm file. I feel kind of stupid. I installed the correct SGC file, and it worked. After I loaded the correct .pccm file, I got the "open com error" when I tried to read the file from the display without first loading the original .h file. Once I saved a file to the display, reading worked fine.

      The link for the SGC .pccm file on the Products->Download tab doesn't work. It says the file cannot be found. I had to monkey with the URL to get to the right page.

      Thanks for the help and time.

      Take care,
      Brian Hood


      • #4

        Can I use the DISP tool with a uOLED32028-P1 with 44DGL pmmc rev 1.08?
        I tried to connect to the display and got the same error as desribed above.


        • #5

          Ok after searching around (because ther is no direct linkt) I found the SGC pmmc ()and the header files. Now I can connect to the display but the 'load from display' gives an

          'Range Check Error'

          Then I tried to 'File->Open' the header file uOLED-32028-P1T-v00.h but this gives a

          'Error Parsing File'

          I have a P1 module and not a P1T. Is there a header file without the touch feature available?
          The version of the DISP.exe is


          • #6

            The direct links can be found under the downloads tab on the relevant product page.

            I downloaded fresh copies of DISP, PmmC and P1 and P1T headers for the following tests.

            The 'range check error' occurred in an earlier version of DISP, I cannot repeat this in DISP

            The 'Error Parsing File' issue was present on header files dated prior to 2 Nov 2009, it was caused by the uploaded converting the files into 'Unix' style(i.e. no CR).

            No harm will come from loading a P1T header into a P1.

            DISP is only for SGC PmmCs