Announcement

Collapse
No announcement yet.

Module Dead after trying to load pmmc

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Module Dead after trying to load pmmc

    I am having a problem loading a pmmc. i have loaded the gfx pmmc. Then i reloaded the sgc pmmc. When i tried to reload the gfx pmmc, it erased module but never loaded. Now i can't get it to load any pmmc. The screen remains blank. I have rebooted. Any ideas?

  • #2


    Hi Terry,
    Which display module you are using? Exactly which PmmC you are loading to the module? Could you give us bit details of your setup. like how you connected the module with the PC...
    -Bilal

    Comment


    • #3


      I am using the uLCD-32PT (SGC). It is connected with a usb breakout board from Sparkfun, using the FT232RL instead of the FT232RQ as your interface does.
      The pmmc's that I am using are uLCD-32PTGFX-R22.pmmc and uLCD-32PTSGC-R18.pmmc.
      I successfully loaded the uLCD-32PTGFX-R22.pmmc. I then reloaded the uLCD-32PTSGC-R18.pmmc.
      I went to reload again the
      uLCD-32PTGFX-R22.pmmc. It stopped at "ERASING MODULE" (or something similiar to that was being displayed).

      I have not been able to load either pmmc since and get "waiting for device".

      Terry

      Comment


      • #4


        My assumption is that the memory was in the process of being erased. The process did not complete, so memory is not fully erased and my device is left in a state that it can not restart the erase process to finish erasing so it can not load the new pmmc software. It is DEAD for all practicle purposes. What about warranty options??

        Comment


        • #5


          I would say it is impossible to kill one of these devices in the way you describe, maybe that's a bit strong, but you get the idea, I hope.

          You cannot program a PmmC unless you are passing the reset line to the display.

          Have you got DTR correctly connected from the FT232RL so that it creates the reset pulse required?
          Mark

          Comment


          • #6


            Yes I have the reset to DTR. I have also tried taking reset low then high manually.

            Comment


            • #7


              Is there some way to force a reset to allow the erase and download process to complete? Toggling DTR does not seem to be doing the trick. Any suggestions would be helpful.

              Comment


              • #8


                I had the same problem. Now microLcd-32PT is dead! Is there any way to wake it up?

                Comment


                • #9


                  Hi,
                  I bought two weeks ago two different display: uOLED32028P1T and uLCD-32PT. Both are serial display, but I'd like to change their firmware with the SGX model. I've used the POUSB12 (uUSB) as USB to serial converter and by the Fat Controller both display seems to work fine. I've used the PmmcLoader ver 1.0.0.5 and the older version 1.0.0.1 to change the firmware, but I've got these errors: "Waiting for device" with ver 1.0.0.1 and "unexpected response from display" with ver 1.0.0.5. I don't know how to fix this problem, I've also used the CP210xSetIDs.exe utility to increase the maximum current of
                  USB to Serial UART Bridge Converter, but the problem has not fixed.
                  What's the solution?
                  Thanks, regards, Antonio

                  Comment


                  • #10


                    To reprogram PmmCs your hardware needs to be able to assert the DTR line.

                    Try the relevant part of the circuit here. http://4d.websitetoolbox.com/post?id=4664334
                    Mark

                    Comment


                    • #11


                      Hi, thanks
                      I'm using the uUSB and I've connected the pin 5(Reset) to RES pin of uLCD32-PT is not right or enough to use PmmC Loader?
                      At this link: http://4d.websitetoolbox.com/post?id=4664334, I've found this indication: "You should not use uUSB to interface 4D's display modules with the PC because there is no Reset signal coming through the uUSB which is an integral part of PmmC programming protocol. " Why there is no any indication on uUSB data sheet about this incompatibility?
                      Thanks,
                      Antonio

                      Comment


                      • #12


                        I'm in the same case as above. I have a uOLED 32028, I wanted to turn the SGC version into a GFX. I've previously updated PMMC successfully on those, and the manual asserting of the reset has always worked for me using a low bounce tactile switch, even on the uOLED96.

                        It started with erasing memory, then stalled, I waited > 2 minutes, then switched it off, now it's dead.
                        is there a possibility that the update of the PMMC damaged the bootloader or are we sure the bootloader is permanently stored in the controller ?

                        what's next ?
                        thanks
                        irvin


                        [addon]
                        further debugging :
                        - my TX pin remains low, RX pin is high (serial cable unconnected, just the 5V power supply)
                        - chip doesn't seem to react to reset
                        - oscillator is working

                        another point, for which I'm going to claim warranty for (and that could explain why it's dead). I discovered a huge electrical isolation loophole between the mother board and the oled screen. The pins of the serial port header (reset, gnd, rx, tx, +5V) was going thru the foam tape and was shorting the whole thing. That possibly happened during my pmmc update and explains why it stalled suddenly. For sure it explains why that module has been giving me headaches since I took it of of the mylar bag this morning, it was working screen facing on the table but would go power crazy once I flipped the screen to be able to see it. The pins were clearly pushing thru the foam and it might have passed the QC, however it failed after a while (foam flattened or pins broke thru)

                        those headers should be *flush* the other side. I had to extract them, then clean the holes with copper braid but even with that, no luck, chip isn't responding.

                        any hint ? to avoid changing the whole board and wasting $180, I'm happy to try to change the picaso chip myself (EE, used to rework board with a hot air station etc)

                        please advise,

                        Irvin

                        Comment


                        • #13


                          In the normal scheme of things using the 'proper' way of doing a reset it should be impossible to damage the bootloader.

                          However, if you are generating your own resets and along bounces an extra reset, well, there's a chance you could be in trouble.

                          Even if the display appears dead, you should be able to reprogram it, have another go.
                          Mark

                          Comment


                          • #14


                            I tried again, with no luck (please read my edited post above where I describe the electrical failure of the screen I got)

                            just to be sure : do you confirm there's usually no issue for uploading a GFX pmmc into a screen that was originally sold as a SGC ?

                            thanks
                            irvin

                            Comment


                            • #15


                              irwin,
                              best to contact tech support ([email protected]) to resolve your problem..
                              Atilla

                              Comment

                              Working...
                              X