Announcement

Collapse
No announcement yet.

Unable to play audio

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to play audio

    Hello,

    I recieved my Somo 14d last week and my aim is to use it in Key mode to play various sound effects triggered by a microswitch in a basic game. I have plugged it into a mini Breadboard. It is powered by 2 x AA batteries. I have added a LED to the busy pin. I have a switch from the play pin and to gnd. I have a 8 ohm .5w speaker connected to the + and - pins. I have another microswitch which I have been trying in either the Next or Previous or Reset Pins. The SD is a Sandisk 2gb which is formatted to 32kb. I have tried both the sample sounds and some Mp3 sounds I have converted using the Software tool.
    The Led blinks when the play and or the other switch is pressed and I can here a very faint high pitched (2) tone from the speaker.

    Is there something obvious that I am missing ? Any help gratefully recieved.

    Many thanks

  • #2


    The SD is a Sandisk 2gb which is formatted to 32kb.
    Hmm, the disk must be formatted using FAT16 (or just plain FAT), but I'm not sure what you said above, you may have been referring to 32kb cluster size
    Mark

    Comment


    • #3


      Hi, Yes I have formatted to FAT. The 32KB is the allocation unit size. I have spoken to my Supplier today who thinks it may be the type of SD card although I see other forum users have had success with the 2gb Sandisk. My supplier is going to send me a card loaded with sounds that definatly works on his system.
      I have added switches this evening to the previous, next and reset pins to see if that helped. The LED lights when all of these are pressed but still only the low volume, high pitched 2 tone is audible.

      Any thoughts ?

      Comment


      • #4


        Yeah, would have thought 2gb Sandisk would be fine.

        The high pitched sound you hear is most likely the PWM whine, which would tend to indicate the sounds haven't been converted properly, or were not suitable for converting (the software is not very good at telling you that

        Are there any pre converted sounds you can try?

        Actually, with such a friendly supplier, I'd probably wait for him
        Mark

        Comment


        • #5


          I have loaded the 4D sample sounds which seem to give the same effect. I'm happy to wait for a card from the supplier if there is nothing else i am obviously missing.
          Thanks

          Comment


          • #6


            I recieved the loaded SD this morning from my freindly supplier. Unfortunately there is no difference at all in performance between this and he card I have been using. All i get is very low volume static or occasionally a 2 tone signal which is barely audible.

            Do you think there is a possibility that the SOMO 14d is faulty ib some way ?

            Comment


            • #7


              Hmm, have you definitely got adequate VCC (3.3v ~50ma with and adequate C (220uf) across it close to pins 8+9. If you don't have the C it wont work very well.

              What about the speaker 4, 8 or 16 ohms across pins 11+12?

              Have you tried connecting audio out to some PC Speakers? Some people think the internal speaker is a bit 'soft'?
              Mark

              Comment


              • #8


                Hi,

                I have had the same problem reported here - crackling / hissing / squeaking coming out of the speaker.

                The only cards that have worked for me are 1GB SanDisk cards - 2GB SanDisk and 2GB Kingston don't seem to work

                Also, I found that the cards that DO work only do so with a supply slightly over 3.6V (~3.65V seems to work).

                To clarify: I have used the 220uF decoupling cap, as well as a 0.1uF cap in parallel, and every other fix that people have suggested (removing busy LED, etc etc).

                There is one exception - I actually have a bunch of SOMO modules (about 10). Most of these have serial number 081210 or 061210, all exhibiting the same problem (~3.6V required). I do have one with serial number 151510 that seems to work much better than the others. In particular, I am able to power it at anything between +3.3V and +3.6V. However, it also only seems to work for me using the 1GB SanDisk cards. This is a problem, because they're not very easy to get anymore!

                At a glance, the only difference between the 081210/061210 and the 151510 is a different part used for transistor in the corner (undertnead the "www." of the 4D systems URL). In the former, the part is labelled J3Y, and the latter it's labelled HHFG.

                Can someome from 4D please verify whether this might be the issue, and if so could you suggest a replacement part that might fix the problem?

                Comment


                • #9


                  I have noticed exactly the same. Using a Kingston 2Gb uSD card, I had just very quiet clicking noises output when supplying 3.3v to the device. When I bumped it up to 3.7v, the files played back fine.

                  Comment


                  • #10


                    Hello, I have now ditched the AA batteries and got a 3.3 power module (schmartboard) from a 12 adapter. I am using a 2G sandisk SD. I have converted 24 wavs and Mp3s into the .ad4 using the soft tool. I then renamed the files as 0000.ad4, 0001.ad4 etc, etc, and everything works perfectly. This is running in simple key mode for a game sound effects. I have a reset button, a play button and 3 next buttons. It all works very well with no clicking or buzzing from the speaker.
                    I am very pleased with the SOMO 14d now !

                    Btw, I had an idea to run an array of LEDs from the busy pin to light up when any of the buttons is pressed. Is this an acceptable/simple thing to do ? How many LEds would it be able to light momentarily ?

                    Many thanks

                    Comment


                    • #11


                      Comment


                      • #12


                        Hello,

                        I just received a new SOMO 14D module and have set it up in keymode for testing (ultimately I will be interfacing with a microprocessor). Everything is mounted on a breadboard per your reference circuit, but I am unable to get any sound to play back to the speaker - not even any popping or whining as some have described. I am using a 2GB Sandisk card, which should work according to some of the various posts that I have read. The LED lights up, as if there was something playing back, but absolutely nothing comes out of the speaker. I checked the speaker out lines with a scope and there is only a tiny waveform present - and a constant one at that (nothing that would indicate real audio). I am using the sample audio files from your website.

                        Any ideas?

                        Thanks,

                        Oliver

                        Comment


                        • #13


                          Which reference circuit are you referring to?

                          Have you got 200uf close to the power pin on the SOMO?

                          What is the voltage at that pin?

                          Is the uSD card definitely formatted as FAT?

                          Have you tried a different card?
                          Mark

                          Comment


                          • #14


                            Reference circuit #2 from here: http://www.4dsystems.com.au/downloads/Audio-Sound-Modules/SOMO-14D/Docs/SOMO-14D-Applications2.pdf

                            I am using a 220uf cap that is right next to the power pin on the SOMO. The voltage on the pin is 3.3V. The uSD card is definately formatted as FAT. I initially tried a PNY 2GB card, but had similar results, so I hunted around for a Sandisk 2GB card, which has been cited as a working card in several forums. Note that it is very hard to find a 2GB or smaller card. I did notice that the LED does stay lit for longer with the Sandisk card than with the PNY card, if that means anything.

                            Comment


                            • #15


                              Only other thing I can think is to ensure the file names are 0000.ad4, 0001.ad4, etc.
                              Mark

                              Comment

                              Working...
                              X