No announcement yet.

Module not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Module not working

    I recently bought a SOMO-14D and it arrived yesterday.

    Unfortunately, I cannot get it to work. I have wired it as per the datasheet using an Arduino as the controller.

    I send a "play file" command and I get a high pitch whine from the attached speaker. The "busy" pin goes high when the noise starts and goes low when the noise ends (about 12 seconds later).

    All the information I can think that may be useful:
    • VCC is connected to 3.3v on the Arduino (and gnd to gnd suprisingly enough)
    • "reset", "clock" and "data" are connected to digital io pins set as outputs
    • "busy" is connected to a digital io pin set as an output
    • The speaker +/- are attached to an 8ohm 0.5w speaker
      The SD card is 512mb and formatted as FAT.The ad4 files I am using were downloaded from have used two different pieces of downloaded source code and have also written my own version. They all show the same behaviour.It doesn't matter which ad4 file (out of those available from the 4dsystems website) I choose to play, the noise (and busy line) lasts 12 seconds.

    Anyone offer help and/or a solution or do I have a faulty board?

  • #2

    The problem you are having is very common, read the next thread and see how the next person solved it.


    • #3

      I couldn't see anything on that thread that anyone said was the solution.

      There is also a difference in output compared to the previous thread. I don't get a 2 tone noise or static, I just get a single, low volume, high-pitched tone for 12 seconds no matter what I try to play.


      • #4

        Please try some extra C on VCC and / or a different make of uSD card


        • #5

          Just to close this thread off...

          Adding a capacitor didn't fix the problem.

          Now having tried 5 different SD cards of varying sizes and brands, I have found one that works (Transcend 1Gb SD).