Announcement

Collapse
No announcement yet.

uVGA-II - Test program observation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uVGA-II - Test program observation

    Hello,
    I am running the uVGA-II with uVGA-II-GFX-R24.Pmmc. I have loaded Tmrevent.4DG to flash, and placed GFX2DEMO.GCI and GFX2DEMO.DAT onto the uSD card.
    Everything appears to run fine, after ten seconds or so everything speeds up, as expected.
    However, If I leave the program running for a significant period of time (10 mins or so), the gear animation becomes jerky and slow...
    What would cause this? A convergence of the timer events?
    Also, in the program, where is IMAGE_INDEX defined? How can I tell what include files are being linked in during compilation?
    Thanks!
    _______________
    Best Regards,
    Howard

  • #2


    Hi,
    the file *.pjt will show you what is linked.
    IMAGE_INDEX is a constant defined in the *.fnc file.

    A test will be run later to determine your other q, what you are saying about timer convergence is probably correct, but will give it a run and observe behavior and report back.
    Regards,
    Dave

    Comment


    • #3


      Thanks for the info, Meldavia. That is very helpful.
      Were you able to run the test? I want to make sure it is not a problem with my hardware, or something else I am doing......
      Thanks!
      _______________
      Best Regards,
      Howard

      Comment


      • #4


        Hi yes I did run the test, on a 32028 and same thing happened - it slows down, and left for quite a while bogs down to about 1second per refresh for the 10gear image. Will be doing some analysis over the weekend to try and figure out whats happening. Will post results ASAP
        Regards,
        Dave

        Comment


        • #5


          Thanks for your effort regarding this, it is appreciated.....
          _______________
          Best Regards,
          Howard

          Comment


          • #6


            Hi Meldavia,
            Any luck pinpointing the issue?
            Thanks!
            _______________
            Best Regards,
            Howard

            Comment


            • #7


              Hi Howard,
              yes it took a little while to pin it down. There is an issue with with the timer function queue, under certain rare circumstances (timing related) events are missed. As there is no workaround other than using the timers polled, the problem has been fixed for a new PmmC release. There are a few other minor issues being attended to also. New PmmC will be available asap, hopefully Friday - Monday latest.
              Regards,
              Dave

              Comment


              • #8


                Nice.......Good Job!
                _______________
                Best Regards,
                Howard

                Comment


                • #9


                  Just an update, loaded the new R25 PMMC and have had the example running for 24 hrs, no slow down observed, so it looks good.
                  Thanks!
                  _______________
                  Best Regards,
                  Howard

                  Comment

                  Working...
                  X