No announcement yet.

Problems editing fonts

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problems editing fonts


    I have a problem when I try to change the fonts in the DISP Tool.
    I'm using the last version on web of the program ( and in general is fine using the default DISP Config File of my uLCD-28PT (uLCD-28PT-L-V00.h).

    But when I delete an existing font, or when I add a new one, the program returns a "Range check error" when I try to reload the file.

    Also, checking the config file it appears:
    [quote]SYSDATA3 fWidths16x20[120] = {
    6, 6, 9, 0x0C, 0x0B, 0x10, 0x0F, 5,

  • #2

    There's no problem with hex and non-hex numbers in the .h file, DISP reads them either way.

    DISP is certainly creating the wrong file (for fonts wider than 15 pixels), from what I can see of your file it should look like this:-
    SYSDATA3 fWidths16x20[120] = {
    6, 6, 9, 0x0C, 0x0B, 0x10, 0x0F, 5,
    7, 7, 0x0A, 0x0C, 5, 8, 5, 0x0A,
    0x0C, 0x0C, 0x0C, 0x0C, 0x0C, 0x0C, 0x0C, 0x0C,
    0x0C, 0x0C, 7, 7, 0x0C, 0x0C, 0x0C, 0x0B,
    0x10, 0x0D, 0x0B, 0x0C, 0x0D, 0x0A, 9, 0x0D,
    0x0C, 5, 7, 0x0B, 9, 0x10, 0x0D, 0x0E,
    0x0B, 0x10, 0x0B, 0x0B, 0x0B, 0x0C, 0x0D, 0x10,
    0x0C, 0x0B, 0x0B, 8,
    0x0A, 8, 0x0C, 0x0C,
    7, 0x0A, 0x0B, 0x0A, 0x0B, 0x0B, 8, 0x0B,
    0x0A, 5, 6, 0x0A, 5, 0x10, 0x0A, 0x0C,
    0x0B, 0x0B, 8, 9, 8, 0x0A, 0x0B, 0x10,
    0x0A, 0x0B, 9, 8, 0x0B, 8, 0x0C, 0x0A,
    0x0C, 0x0A, 0x0A, 0x10, 0x10, 0x0C, 0x0C, 0x0C,
    0x0A, 0x0A, 0x0B, 5, 0x0C, 0x0A, 0x0A, 0x0D,
    0x0A, 0x0C, 6, 0x0A, 0x0A, 0x0B, 0x0C, 6 } ;
    SYSDATA3 fWidths33x45[16] = {
    0x1A, 0x21, 0x10, 0x11, 0x0E, 0x21, 0x20, 0x13,
    0x1F, 0x1E, 0x21, 0x1E, 0x1F, 0x1D, 0x1F, 0x20 ) ;
    SYSDATA3 font_8x12[] = {.....
    Hopefully you can write it to the display before saving and/or fix the file as described above (it worked for a file I tried).

    I will look into disxing DISP asap, but it might be next week sometime.


    • #3

      Thanks for your fast reply.

      I have modifed the config file, and I have had the same error (Range check error).
      Also, I only need to delete a default font to have the same problem (not only for a inserted large fonts).

      I think there's a general problem modifying fonts.

      I'll wait for a new release. Thanks.


      • #4

        Just a quick update.

        It's not the config file that is causing the problem, ignore the 'errors', they do not affect DISP's operation.

        The "Range Check Error" is, I'm pretty sure, caused by the 'Splash' screen, attempting to reference a non-existent font.

        The default splash references font 3 (the 4th font) quite a bit. When you save the config file without the 4th font and leave the Spalsh referencing it, you get a "Range Check Error" when you reopen the config file.

        So, if you are reducing the number of fonts make sure you change the 'Splash' screen first, or at least before you save the file.

        That said, I wont be fixing this in the next week or so, it really needs some more thought as to the best way to do it, OK?