Announcement

Collapse
No announcement yet.

Serial not responding at the same speed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Serial not responding at the same speed

    Hi,
    I'm using a uLCD 128, MKI. Old, I know, I have had it for quite a while now. Using it simply for debugging purposes now.
    As the name of the topic says, it is not responding at the same speed. After sending it a 0x55 (or any message thereafter), at 125000 baud, it responds back at about a thousandth of that speed (not exact, but pretty close to).
    The annoying part is that it only does this sometimes, then it can suddenly decide that it is going to start working again.
    I don't think it is a connection problem because it is clearly getting the message, it's just not reading it for some reason.
    I have tried it in another project I worked on before and it never has this problem.
    The pic I am using is sending at the proper speed every time though so I don't really know what the problem could be.
    I have tried at different baud rates but this doesn't seem to be changing anything.
    Could it be a rise and fall time issue? What is the maximum rise and fall time?
    Thanks and regards

  • #2


    Can you tell me exactly what a "uLCD 128, MKI. Old" is? I've got several possibilities in mind and I'd like to focus on one. What's it got written on the board? What PmmC is loaded in it?

    Does it always work at 9600?

    Maybe it can't quite lock on to 125000, which is a bit 'non standard'. Perhaps try 115200.
    Mark

    Comment


    • #3


      There's not a whole lot written on it. It's got a sticker with uLCD MK I over the quad. It's apparently old enough that you don't even have it listed as 'discontinued' anywhere that I can see. For inputs, all it has are 4 pins. GND, Rx, Tx, +5v.There is room for a 10-pin header, an 8-pin ic labeled only as 'u4' and a spot for a USB input labeled 'micro-USB on the board but they are not populated.
      I have tried it at 9600 but it didn't change anything. I have no idea what pmmc is loaded. It would be whatever it came with as there is no way to connect it (simply) with a computer.

      Comment


      • #4


        Hi, that old module is pre-PmmC days, so theres no way of upgrading it, however they are still a good old clunker as long as they are in working order.
        From what you are describing it seems like autobaud is getting confused and locking onto a wrong baud rate. Try it out at 9600 baud if you can to verify that it is actually working, then try higher baud rates.
        Regards,
        Dave

        Comment


        • #5


          I think you're right about the not locking-on properly part but I don't know if it's simply the baud-rate that's the problem as I have tried it at 9600 and 115200 to no gain. It has worked at 9600 but it has also not worked at 9600.
          It was a sudden change too as it had been fine at 125000 for a few weeks up until now.

          Comment


          • #6


            yeah, could be dead, but just check things like logic levels, power supply, grounds etc - Murphy may be playing tricks !!!!
            After all, it does 'sort of work' - I dont know what your driving it with, but make sure you are quick enough to get the ACK, and make sure you wait for an ACK before proceeding to send more commands.
            Regards,
            Dave

            Comment

            Working...
            X