Announcement

Collapse
No announcement yet.

Creating New Fonts

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Creating New Fonts

    I have spent some time creating a few new fonts with the Font tool and then importing to the Disp tool.

    Mostly all is ok, I have some large numbers that work fine and in the same font I have created a degree centrigrade symbol, also ok. Then I have another symbol and this will not display (nothing is displayed).

    Today I have created some battery symbols from full to empty using a new font, the symbols use ten characters, 0 to 9. These all print blank.

    In the Disp tool everything looks perfect for all the charaters in all the fonts and these download to the dispaly with no problem. But in the new fonts I have created some or none of the characters print on the display.

    I am printing using the graphic command $53, not scaled but have also tried other text printing commands.

    Disp version 0.1.0.22

  • #2


    Can you post the font, or email it to me mark@4dsystems.com.au
    Mark

    Comment


    • #3


      I have managed to get this working.

      I found that the fonts I created with the Font tool seem to be corrupted in some way. Once I have imported the font to the Disp tool if I edit a character, just change a pixel or something then replace it, then it works. So I just went through and replaced all the characters and they worked!

      I noticed that if I copy a character and then paste it back the green outline shifts a pixel, maybe this is a clue?

      Thanks again for the prompt reply, I emailed the font earlier today.

      Comment


      • #4


        The characters that aren't working seem to have a character width that is wider than the font width.

        The font editor in DISP is 'limiting' the maximum value displayed to the font width and so replacing the broken chars 'fixes' them.

        Font 4 has the same problem with +, 0-9 and the last 4 characters.

        I will look into fixing this in a future release of DISP and FontTool
        Mark

        Comment


        • #5


          I have just tried to make a new set of large fonts and when I import them into the DISP tool I get a Range Check Error when I select them to view.

          In view of my strange computer issues I did try this on another machine as well with the same result.

          Maybe this is a simillar problem to the one that you will fix but I can't open the font to even change it this time so I'm a bit stuck.

          Comment


          • #6


            Could be, if you can let me know how to create those fonts and how to import them I'll have a try, maybe email them to me.

            The is an issue with DISP where it can get a range check issue. If you delete a FONT that is used in the splash screen before removing it from the splash you will get a range check error.
            Mark

            Comment

            Working...
            X