Announcement

Collapse
No announcement yet.

uCAM-TTL won't sync

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uCAM-TTL won't sync

    After trying for the better part of 2 weeks, I’m unable to get my uCAM-TTL to sync. Here’s my setup:

    hardware
    • uCAM-TTL hooked up to USART2 on a PIC18 device
    • power into uCAM-TTL 3.23 volts
    • connections checked repeatedlycodePIC18 is programmed in C18PIC18 USART2 set up for 14400 bps. I’ve tried other speeds - no luck. PIC18 sends SYNC message 60 times: 0xAA,0x0D,0x00,0x00,0x00,0x00, with a 3.6 ms delay between each message. I’ve tried no delay between messages, and a longer delay, to no effect.
    normal;font-variant:normal;text-decoration:none;vertical-align:baseline;">what I observe
    • logic analyzer / oscilloscope observations are taken at relevant pins on uCAM-TTL and PIC18 logic analyzer shows SYNC message arriving at uCAM-TTL pin 5/RX. Logical 0 is around -0.08 volts, 1 is around 3.23 volts. There is never any response from the uCAM-TTL - the camera’s pin 4/TX goes low, but that’s it.
    It is ENTIRELY possible I’m doing something silly, but I’d appreciate any help. I’ve got a max3232 on the way so I can try hooking this directly up to the uCAM demo program via RS-232, but I’ve tried this 6 ways from Sunday on my microcontroller with no luck. Happy to attach images from my scope if this would be of use. Thanks!

  • #2


    I think waiting for the MAX232 is the best bet, for now
    Mark

    Comment


    • #3


      Will do. I'll try it via rs-232 when the driver arrives and report back.

      Comment


      • #4


        Greetings!
        The Auto baud is: Auto detect Baud rates from 14400 baud upto 115200 baud. 8 bit no parity 1 stopp
        so you should be good with a baud of 14400. never the less the default baud in the ucamdemo software is 57600 and since the protocol of the cam seems very fragile I would stick to that baud rate.
        I'm using an arduino board to sync with the cam. and there is a library for a camera with the same protocol called C328R. In any case I sometimes have to send the sync signal over 60 times till it is synced. you should try delaying about 200ms between each 30sync commands.
        :-D Daniel
        Ps:and don't forget to switch the rx and tx pins when connecting to the pc via max232.

        Comment

        Working...
        X