Announcement

Collapse
No announcement yet.

usd can't be detected

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ESPsupport
    replied


    What does the tester in the FAQ section have to say? http://4d.websitetoolbox.com/post/uSD-Card-and-Display-Modules-5149940

    Leave a comment:


  • Chinmay
    replied


    I put the .dat and .gci files but it still shows the disk is not mounted...why??

    Leave a comment:


  • Chinmay
    replied


    I put the .dat and .gci files but it still shows the disk is not mounted...why??

    Leave a comment:


  • romeoromeo
    replied


    Hi, i used an other 2Go µSD and it is working. Now i can't anderstand why.

    Leave a comment:


  • ESPsupport
    replied


    Well, it's a bit of a round about way of doing it, but it should work.
    PROVIDED you aren't using one of those flimsy USB cables. Are you?

    Can you measure the 5v coming into the card? Voltage and ripple?

    Why should we use a USB special cable from 4DSYSTEMS to program something ?
    On the prduct pages it says:-

    Warranty Note:
    PmmC or 4DGL programming should only be carried out using any one of the 4D Programming modules (4D Programming Cable, uUSB-MB5, uUSB-CE5). Any malfunction because of custom or third party USB to Serial converters or Serial(RS232) to Serial(TTL) level converters will void the warranty.

    We don't say that for the fun of it. In addition, many 'other cables' are not wired correctly to reload the PmmC on 4D displays. They may work for general usage, but as soon as you try to reload a PmmC you will get very frustrated.

    Leave a comment:


  • romeoromeo
    replied


    i am using an ARDUINO duemilanove board without ATmega328 microcontroleur. just using the IC FT232RL directly from USB cable.
    I taked off the MOSFET T1 and maked a short cut on the drain/source, and taked off the 5VDC regulator IC4. Nothing better.
    Why should we use a USB special cable from 4DSYSTEMS to program something ?

    Attached files arduino-duemilanove-schematic.pdf (47.4 KB)

    Leave a comment:


  • ESPsupport
    replied


    Another thing to try is to delete the partition table and reformat without it.

    This shouldn't change anything, but the 'first sector' is usually sector 1, so I'm just wondering if that is causing a problem

    Leave a comment:


  • ESPsupport
    replied


    Hmm, ok.

    Most people who have this sort of problem have unreliable power to their display (the USB memory is most sensitive to marginal power).

    How are you powering the display?

    Try a good solid cable (I.e. not a thin one).

    Power it directly from the USB port, not a Hub.

    Leave a comment:


  • romeoromeo
    replied


    Hi, you can see the RMPET.


    Attached files

    Leave a comment:


  • ESPsupport
    replied


    What is RMPET saying the partition type is?

    Leave a comment:


  • romeoromeo
    replied


    Hi, i got a new µSD card of 2MB.
    When i use your prog. µSDtester the screen show me :
    media_Init successful
    No valid MBR or partition
    Table found
    Sector Dump Follows
    FFFFFFFFFFFFFFFFFFFF FFFFFFFFFFFFFFF
    etc....

    Leave a comment:


  • ESPsupport
    replied


    Only FAT16 (or FAT) is supported.

    Where are you getting "partition id 0x0D" this is not a valid partition ID, have a look here http://en.wikipedia.org/wiki/Partition_type

    How are you creating this partition type?

    Leave a comment:


  • romeoromeo
    replied


    Thanks for your support.
    I tried your program µSD tester. When i format in FAT 32 it not working "µSD not formated", if i format in FAT it's better but :
    init is successful, mbr fat 16 unreconised partition id 0x0D.
    This is the most problem, formated in 16 or 32, having or not files in µSD, the screen show :
    part# type start length
    1 0D 64202E72 75717369
    2 50 207A6573 20656E75

    but in fat16 the mount is successful
    do you know why ?

    Leave a comment:


  • ESPsupport
    replied


    See Q1 http://4d.websitetoolbox.com/post?id=5149940

    Leave a comment:


  • romeoromeo
    started a topic usd can't be detected

    usd can't be detected

    Hi, i tried to use DIR example programme with a uLCD-32PT_GFX2, but the screen endlesly show that the disk is not monted. I used RMPET, format the usd, two different capacity usd ( 2G and 1G ). does someone have an answer and explanation ? regards
Working...
X