No announcement yet.

Solid white screen on uLCD-32PT

  • Filter
  • Time
  • Show
Clear All
new posts

  • Solid white screen on uLCD-32PT

    I received a new uLCD-32PT that does not seem to be functioning properly. When connected to power (no program in flash), it displays a solid white screen until it goes into standby, when it turns black. In the previous 32PTs I have had, a new display showed the model number, resolution and version number in green text on a black background.

    if I download 4dgl compiled code to it, it displays nothing but the solid white screen. Workshop indicates that the download was successful.

    I have tried updating the PmmC to the latest version, but the behavior is the same. The date code on the display is 300711.


  • #2

    Was there ever a resolution to this. I am having the same problem with 2 modules both have the same date code.


    • #3

      Please contact 4D Tech Support for help,



      • #4

        Not sure what he did, but he seems to be working now.

        A white screen can be caused by loading the wrong PmmC.

        Check the updated description on the dowloads tab to see if you have the correct PmmC

 (for GFX, similar for SGC)


        • #5

          The screen was defective. I returned it to SparkFun where I bought it. They tested it and confirmed it was not functioning and they sent me a replacement which worked fine.


          • #6

            I have loaded the proper PmmC several times. I did notice that every once in a while (maybe 1 in 10) the module powers up normally. I've used many of these modules (50+) over the last year or so.


            • #7

              That looks final, contact support, as Bilal said below.


              • #8

                I am experiencing a similar problem with two of my ULCD-32PT screens (SI R20 010212). When I apply power, the screen goes white and remains that way. However, the serial communication, touch and sound are still working as expected. I have demolished the first one, because I suspected a mechanical failure, but then the second one started to behave in a similar way.

                And now for the interesting part. If I leave the screen disconnected for a few minutes and reconnect it, it works perfectly and will work normally for days. If I disconnect it and reconnect it to power within few seconds (less than a minute), it will display a white screen. The whole thing is perfectly repeatable, I have tried it on several computers, using uUSB-MB5 and 4D programming cable.

                Is there a solution for this or is this just an isolated case and I should not worry about this when I go to production?



                • #9

                  Hi All,

                  I've just run into very similar problem as described here. Got 3 brand new uLCD32 modules labelled S R20 170212 (see pic)

                  The first module - reflashed the PmmC to GFX-R30 (v3) and everything seemed to work fine, uSD card, sounds, touch, but the screen was always displaying the 4D Systems splash screen and I could not get this to go away. (see pic)

                  2nd module - reflashed and everything seemed to work fine, uSD card, sounds, touch, but the screen was just full white.

                  3rd module same as first.

                  So I took a leap of faith having read that a solid white screen sometimes means wrong PmmC - so I loaded the "i" version - bingo, everything is working fine.

                  All now reflashed with PmmC R30 "i", which is opposite to that indicated on the label and all OK.

                  I'll leave them off for awhile and check them later to ensure no problems as reported by bateng.

                  So are these problems just a labelling error or is something else odd going on ? Is there anyway of determining the required PmmC other than the label ?

                  I have a mixture of both "i" and non "i" displays so have both PmmC files on my PC as downloaded and there are no file naming errors or other "user" errors taking place. Attached files


                  • #10

                    I'm having the same problem. I've installed my uLCD32 in it's application and it's been working for months.
                    Last week I turned it on and the screen is white, blacklight. The touch screen, sounds, and uart still work, but not the screen. I've tried downloading other pmmc files, but nothing works. Any advice? I've had it for over a year and no problems till now.


                    • #11

                      If it just started that way from power up without any program / PmmC changes then you'd have to think it's the display. You probably need to contact support at 4dsystems dot com dot au


                      • #12

                        During development when I've been moving my display from the PC USB Com cable to the target system I have sometimes seen the full white screen appear when I know nothing is wrong.

                        So for example, I unplug the USB cable from the PC and then unplug the 5way Molex header. I go to my target system, which I mistakenly left ON, and I plugged the 5 way header onto the display.

                        This is when I have seen the white screen appear but all other functionality is present just as you describe. Cycling the power to the whole target system with the display correctly connected cures the problem.

                        I realise this is probably not the situation you are in but it makes me wonder if there is a power supply rise time issue or something to do with grounding that might trip the display into showing the white screen. It might be a combination, and the fact that the Picasso initialises the LCD driver at slightly the wrong moment wrt to a rising VCC. I guess it's the driver on the LCD itself that causes the problem as the Picasso is obviously running fine.

                        Check VCC and GND on your project and the display to see if they are OK. Also check the cable between the display and the target system that the power and ground pins are making good contact and the display is not trying to use a signal line as a ground return.

                        On some other older products I've designed that have gone into a slightly "rough" environment we have seen intermittent faults occur on pin header connections. You can't actually see anything wrong with the connection but changing it cured the problem. Try disconnecting and reconnecting several times to ensure the pins are wiped and remove any possible deposits.


                        • #13

                          It's highly unlikely that Picaso is initializing the display 'at the wrong time'.

                          It's more likely, in your case, that the FPC that connects to the display had become damaged and that power/commands to the display are being interrupted at some times.


                          • #14

                            Maybe a bit late, but I faced "all of a sudden" the same issue. I was messing a bit around with the PmmC files, one of them being the latest (uLCD-32PT-I-R34.PmmC, as of this writing).

                            Ever since, after a reset I got a white screen (background?), until the device went into sby. Reflashing version uLCD-32PT-I-GFX-R32.PmmC solved the issue.

                            If I then again flashed uLCD-32PT-I-R34.PmmC, all was fine too... Bit awkward...

                            Just my 2 ct.
                            Best rgds,