Announcement

Collapse
No announcement yet.

problems with GPS-PA6B module

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16


    You are correct. When I specified 7200 and 24000 in my s/w,
    I didn't take care of the routine that sets the dcb baudrate parameter.

    I corrected my mistake and re-tested for 3200.
    The output now contains readable characters, but some are
    clearly wrong. Maybe the comms speed is not exactly 3200, but something
    close to it.
    I attach the output of the stream for you to see.

    So, the following questions come to mind:
    1. how come the modules ended up using this baud rate?
    2. how can I correct them to 4800?
    3. since they did once, will they do it again?

    Thanks very much for your support.

    Attached files gpstrial_3200.txt (3.4 KB)

    Comment


    • #17


      I have no idea how the baud rate ended up as this. All I can think is they were accidentally made this way in the factory, since you can order them with lots of different default rates.



      To change it you will need to find out the correct rate, it's obviously close to 3200, maybe 2800 (as in 4800 with a misstyped 4



      Once you have found the correct baud rate send this command



      $PMTK251,4800*14



      And follow it with a



      That should switch it to 4800 and I think it will stay that way across power cycles (Let me know if it doesn't)



      I would say if it somehow changes again there is something wrong with the chip and it should be replaced.
      Mark

      Comment


      • #18


        Please contact [email protected]

        Comment


        • #19


          Just to close this thread by saying that the module has worked perfectly well. It was a mistake to experiment with the module on the breadboard. 4D support has been of great help.

          I have finally designed my pcb by taking extra care on the ground connection, and placing the LM2936Z-3.3 regulator very close to the module with plenty of capacitance close to the module connections. I did not include the indicating LED and its associated resistor.

          Now the module auto-selects 4800 baud all the time and provides time and position information pretty quickly. Both me and my customer are very happy.

          Thank you for your help.

          Comment


          • #20


            I have same product and having same problems - getting garbage from GPS. I have done everything by the data sheet, all connections and elements in place, backup power supply, low voltage ripple, and can't get it working not matter what I am trying to do. I am getting fix from module and I can see data is coming with 1 sec intervals, but can't read it. I believe problem is with baud rate. I tried 4800, 9600, 3200 and others and just getting nowhere.

            Comment


            • #21


              What are you connecting it to and how?



              Do you have a scope available, so that you can perhaps calculate the actual baud rate?



              Can you give a few seconds of what you are seeing, at, say 9600?
              Mark

              Comment


              • #22


                I have connected it to PIC16F886 and display characters on LCD. I use 2 different USE RS232 streams, both with 4800 baud rate. I do have scope.
                Timing for 1 bit is 200us

                Sounds like another odd baud rate... 5000. How come?

                Comment


                • #23


                  I got it working at 5000 baud... Weird, but working..

                  Can you please tell me how to get a magnetic declination? It says chip supports it but there is no data provided in a sentence.

                  Comment


                  • #24


                    Another weird behavior: coordinates it's showing about 500 meters off from my location. Always. I am getting 3D lock with at least 11 satellites, all data present and good. Any ideas why?

                    Comment


                    • #25


                      How do you know it's 500m out?



                      If you are calculating / converting / rounding please check your calculations.



                      As I recall one 'commonly found' routine on the net only converts one of the figures to 4 decimals and you need to goto 6 to get 'proper' accuracy.
                      Mark

                      Comment


                      • #26


                        Also check the measurement units. (although that usually causes larger than 500m errors)
                        Mark

                        Comment


                        • #27


                          I follow data sheet and this is what I enter in googlemaps:
                          Lat: ddmm.mmmm (should read as .ssss in data sheet)
                          Lon: dddmm.mmmm

                          First two char for dd is for degrees, then mm for minutes, then last for for seconds, I.e:

                          This is what I am getting from module: for lat: 4218.4506 , for Lon: 07112.0733
                          Here is how I enter in googlemaps and it is about 500 meters off.

                          42 18 45.06
                          -071 12 07.33

                          I did convert to decimals and it show same location

                          I compare geographic coordinates from module vs geographic coordinates on
                          iPhone
                          Gps reading on my iPhone is slightly different and show accurate location.

                          Comment


                          • #28


                            Try assuming the datasheet is correct.



                            Convert the fractions of minutes into seconds and then put that into google maps
                            Mark

                            Comment


                            • #29


                              Its difficult to assume data sheet is correct because it has a wrong baud rate on it 9600 when it should be 4800, but even then it is 5000 on some reason on device itself. Or may be I am just unlucky

                              Thank you for advice, I will try.

                              Comment


                              • #30


                                It is unfortunate about the baud rate, it should be what the datasheet says and we are sorry that it isn't



                                As you can see further down in this thread you can change it to whatever (with in reason) you want it to be. (err, once you have found out what it currently is, that is)
                                Mark

                                Comment

                                Working...
                                X