Announcement

Collapse
No announcement yet.

?LCD-32PT problems with uSD card

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ?LCD-32PT problems with uSD card


    hello,

    just got the 32PT two days ago and just had time to transfer the needed files and compile and run 4D Labs\PICASO GFX2\PICASO - DEMO. All apps ran OK and everything was fine.

    Last night I wanted to start working on my project and first thing I noticed, the DEMO app (which was already loaded in flash) was no longer being able to mount the uSD.

    I tried everything I could think of:

    - used PmmC tool to reload uLCD-32PTGFX-R25 profile

    - loaded DEMO app and ran it from flash or ram, tried with other demos using FAT mounting capability

    - (quick) formated card in Windows 7 x64 with differend allocation unit sizes

    - tried with a different uSD card (both 2GB)

    All these without any success. The single thing that seems to work is the media_init function that properly detects when I plug in the card or not. Must mention that both cards work fine in Windows or my mobile phone

    So.. what am I doing wrong? Could it be a hardware fault or what?
Working...
X