Announcement

Collapse
No announcement yet.

TIMER EVENT demo not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TIMER EVENT demo not working

    Hi to alls,
    I've just received my uLCD-32PT_GFX2, and i'm new with 4DGL , but not with this "C" type of language.
    Trying to view the demos with Worshop, i've problems with the demos who use the timers.
    The TimerEvent demo just show me some text in green on the top of the lcd and two gears on the bottom, but the gears don't move, and I can't exit from the program.
    I've tried to download in ram and in flash, but i have the same problem.

    Does anyone help me ?

  • #2


    To be able to see the gears, it seems like you have succesfully loaded GFX2DEMO.GCI to the disk,
    Will test the demo tomorrow with lates PmmC, try it, and get back to you.
    In the meantime though, I'm wondering if you may have inadvertently formatted the disk as FAT32 instead of FAT16?
    Regards,
    Dave

    Comment


    • #3


      Thank you for the fast answer.
      No, the sdcard is formatted in FAT16.

      BR

      Comment


      • #4


        Hi, me again,

        I've tried different workaround, and here are the results :

        If I comment the two following lines :
        sys_SetTimerEvent(TIMER2,gears);
        sys_SetTimerEvent(TIMER3,number);

        The programm runs, I see the stars, circle etc and I can exit the program. ...

        As I have commented the 2 lines, I don't see the Numbers and the gears, of course.
        Does it means that the problem is due to bad SD card access ?
        The sd card I use is a Micro SD HC Sandisk 4GB.

        Regards

        Olivier

        Comment


        • #5


          Yes I was about to get back to you with that conclusion,
          The demo runs successfully here, so it is suggested that you have a faulty uSD card.

          There is also a small possibility that there is insufficient power.

          Are you using a CE5 or MB5 ?

          Are you using a good quality USB cable? - if you have a spare, try another.
          Regards,
          Dave

          Comment


          • #6


            Hi meldavia,

            I've powered the µLCD with an external 5V/500mA PSU and the problem is the same, so the power is not the problem .

            I think the problem comes from the USD card, but I use it on STM32 target without problem (but formatted in FAT32) !?
            I'll try a new one today;

            For the CE5 or MB5 level shifter, I don't use them, I use an Parallax Propeller
            Prop Plug (FTI232) modified to give the USB Vbus power to the µLCD.
            It works fine, as I can download to Ram or Flash every example.

            It seems that the problem is only with images files, with the RunDemos example,
            the TIMERS and AVI DEMO are the only ones who don't run correctly, in the first one nothing run, and in the second one, I can see a little movment in the bottom left image (

            Comment


            • #7


              Hi,
              Problem solved.

              I've tried two news sd cards, a 2Gb VERBATIM, a 2Gb TRANSCEND
              formatted in FAT16/ 64KB sector.
              Same problem.
              formated in FAT16/32KB sector
              GOAL, problem solved ...
              The first SD card (a 4GB SANDISK) refused to be formated in FAT16/32Kb sector...
              Meldevia, what do you think about this ?
              Does the SD card need to be formated in FAT16/32Kb sector ?

              Best regards

              Olivier

              Comment


              • #8


                Hmm, it shouldn't matter.



                Anyway, thanks for the update, we'll look into it.
                Mark

                Comment

                Working...
                X