Announcement

Collapse
No announcement yet.

uDrive unresponsive

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uDrive unresponsive

    Hi folks,
    Received a uDrive yesterday however was not able to successfully communicate with it from an Arduino. I attempt to send a 'U' character (or any characters) however receive no response.

    Set up:
    Arduino mega, hardware serial pins 0 and 1 connected to the uDrive.
    uDrive powered off the Arduino's 5v.
    Lexar SDHC card 4gb, FAT16.
    (Have also tried powering from the Arduino's 3.3v and using a level converter on the serial lines with no change in effect.)

    Steps I am performing:
    1. Power up (the uDrive's power led turns on for one second, then turns off???)
    2. 1 delay to ensure drive is ready
    3. Begin serial @ 9600
    4. Transmit U char
    5. Poll rx for ACK/NAK

    Of course I've tried many more scenarios than this, however I don't see why this basic one wouldn't work. Nothing seems to convince the drive transmit anything. Not even garble on power up.

    Any tips?

  • #2


    Woody,

    Try resending the autobaud command every 0.5 s, or if you see anything happen on the transmit line. There is an old post on the subject - http://4d.websitetoolbox.com/post/Cant-get-uDrive-talking-to-HCS08-4611745?highlight=start+autobaud+command

    When I apply power to the micro-Drive, I first see its transmit line go high, pulse low and return high, then exponentially decay to 0 V and stay there. It accepts an autobaud command after this decay. I'm not sure if this voltage-drop is supposed to mean something.

    Regards,
    Michael

    Comment


    • #3


      Well, wonders never cease. Tried again today and it is ACKing properly. Can't think of what I'm doing differently to the first time, but either way whatever it was is fixed now. ACKs first time and every time.
      Thanks for your advice, Michael!
      Cheers

      Comment


      • #4


        Hi everybody, I happen to have the same problem but instead of no response it gives me back a char 'x' or 117 117 or 62 117. I tried formatting the SD, to re-power up, and checked on the tension levels but I cant' really see what's wrong. Any help?Thanks, Martina

        Comment


        • #5


          It doesn't need a uSD card installed to talk to it, so let's start without one.



          Connect power and serial (What level is it) and wait a fe seconds.



          Send the autobaud character (what speend are you sending it at) and what do you get back?
          Mark

          Comment


          • #6


            So we connected it's Rx and Tx line to the serial port of a pc (we did use the 220R). Is there any chance it's ruined and that's why it's unresponsive?
            Cause after power up and serial connection i did wait a few seconds to let it settle before sending the autobaud character ( 9600 ).

            Comment


            • #7


              The serial port of a PC is RS232 levels (+-12v) the uDrive requires TTL levels (0-3.3 or 5v)



              You need a level shifter (eg MAX232) if you want to connect it that way
              Mark

              Comment

              Working...
              X