Announcement

Collapse
No announcement yet.

micro-Drive Resetting after AutoBaud Command

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MichaelI
    replied


    Turned-out that the power supply had developed a fault - its browning-out must have caused a reset on the drive itself.
    Thanks anyway,
    Michael

    Leave a comment:


  • 4dTechSupport
    replied


    Did you update the PmmC file on the uDrive? Could you try and increase the 'wait period' from 0.75s and see if that works. You can leave the 'Reset' pin floating if you are not using it (It's pulled up internally.). If you wish to use the 'Reset', make sure it is set HIGH at all times. The module gets 'Reset' on a single LOW pulse, also it is set to start PmmC loading routine within 300ms of power-up/reset if it receives certain pre-emble.
    -Bilal

    Leave a comment:


  • MichaelI
    started a topic micro-Drive Resetting after AutoBaud Command

    micro-Drive Resetting after AutoBaud Command

    I have a micro-Drive that was working but is now resetting itself every time I try to send an auto-baud command ('U').

    My software applies power to the micro-Drive (separate power supply), waits 0.75 s then sends an auto-baud command. If no response is received, then the auto-baud command is resent every 0.5 s or if the micro-Drive Tx line drops (interpreted as a "break" or some sort of error by the receiving UART).

    Monitoring the reset, transmit and receive pins shows the micro-Drive applying a reset after every auto-baud is sent. Our circuit board with the micro-Drive does have the capability to drive the reset circuit through a transistor with the collector connected to the reset pin, but I have confirmed that the transistor is not been driven on a DSO.

    A second board with the same software is working fine.

    Assistance would be appreciated.

    Regards,
    Michael
Working...
X