Announcement

Collapse
No announcement yet.

[Solved] uLCD32-pt dosen't show up in the windows 7 64bit devices list?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [Solved] uLCD32-pt dosen't show up in the windows 7 64bit devices list?

    Hello everyone!

    I have purchased a 3.2" uLCD32-pt touch screen(http://www.4dsystems.com.au/prod.php?id=113) and have also purchased the 4d programming usb cable(http://www.4dsystems.com.au/prod.php?id=138). I have installed the following 4d systems usb cable drivers for windows and when I look at the hardware/devices list in my windows 7 it still lists "SM Bus controller"..

    I have tried restarting my computer to allow newly installed drivers to take effect(Didn't work)

    I also know that the SM Bus controller i'm looking at in the devices list isn't being mistaken for with another device as when I unplug the 4d programming usb cable it disappears.

    Am i missing another component? or missing some software or a step?

  • #2


    That sounds very odd.



    It could be that your computer is adding the 'SM Bus Controller' to help it address the programming cable. (i.e. it adds multiple devices when you insert one)



    When you insert the cable an entry should appear in 'Ports (COM & LPT)', are you saying nothing appears there?
    Mark

    Comment


    • #3


      Thanks for the quick reply -- You're correct by the way... Instead of showing up in Ports (COM & LPT) it shows up under "Other Devices".

      Comment


      • #4


        I'm on a 64-bit -- do these drivers not support this?

        Comment


        • #5


          Win7 64bit? Many of us are using that and it works fine.



          Other devices, with a yelow question mark?



          Can you post the screens (properties, etc.) associated with the added device?
          Mark

          Comment


          • #6


            Now i'm trying on a friends computer its a fresh install of windows 7 64 bit. The LCD device doesn't even show up on the device list when i plug it in

            Comment


            • #7


              It should show up under com and lpt ports like this.



              If you plug it into a 'new' computer without installing the drivers does windows try to install the drives for you?






              Attached files
              Mark

              Comment


              • #8


                Yeah there isnt any coms/port at all on either computers, on my computer it attempts to install but always tells me it fails to install(automatic windows installer) however the drivers found on the products website installs flawlessly with out errors, on my friends computer its dosent even register that anything is plugged nor does scanning for hardware changes work either.

                I tried installing the Linux drivers for my Ubuntu system but when i ran ./makerpm it says failed to build rpm which is expected scince ubuntu is a debian system.

                So im wondering two things..
                1) is there a driver file i can point windows to instead of relying on the premade installer?

                2) is there something im missing for linux installer? Or is there an installer for ubuntu?

                Comment


                • #9


                  The programming cable uses the drivers from the chip manufacturer's site which can be found here:- http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx



                  The Windows driver you have downloaded from their site is the same as you downloaded from our site.



                  The Unix version on their site is a bit newer. There are also some more directions there that might prove helpful.



                  Have you tried reinstalling the drivers with your antivirus procut disabled?
                  Mark

                  Comment


                  • #10


                    I have been mistaken, apparently my LCD display dosen't even register on either windows 7 64bit systems... The lcd display powers up but it dosen't show up at all in the device list. This is odd.... i purchased another lcd display just to see if i have a bad one... I hope this works and i'm not spending more money...

                    Comment


                    • #11


                      The LCD display does not register under windows.



                      Only the programming cable does, or should.



                      Since Windows is 'detecting' the cable it would seem unlikely that the cable is faulty, but by all means try another one.
                      Mark

                      Comment


                      • #12


                        Can you run the 64 bit version of USBDeview from here

                        http://www.nirsoft.net/utils/usb_devices_view.html

                        'Select all' then save all selected items to a file, zip it up and attach it?
                        Mark

                        Comment


                        • #13


                          Okay so I ordered a 2nd LCD display same exact model I'm having issues with and so I got it in the mail today and plugged it in, same thing.

                          It powers up....
                          Displays splash screen.....

                          windows never catches wind of the device being plugged in at all!

                          for those whom don't know I titled the thread "uLCD32-pt dosen't install properly still shows up as SM Bus controller? " well I was mistaken and I'm going to correct my self and saying that SM Bus controller is something else not related to this, i original thought SM Bus Controller was showing up and dissapearing at the same time i was plugging and unplugging the device.

                          So I've also included the usbdevices output like ESPsupport suggested while the device was plugged in hopefully this helps debug whats up with my windows 7 system. Now that 2 lcd displays arn't working with windows It has to be the windows 7 system is what im thinking.

                          Comment


                          • #14


                            As I said earlier (amongst other things)



                            "The LCD display does not register under windows.



                            Only the programming cable does, or should."



                            You don't even need to attach this display to the cable, just plugging in the cable should cause it to be registered.



                            Where's the attachment? I can't see it, maybe you need to zip it up?



                            I'm thinking it's more likely the cable is faulty, but since windows seems to recognise it one would think it must be ok.



                            I use it on Win 7 64 bit all the time, so blaming Win7 seems to be out.



                            Anyway let's get that USB devices list.
                            Mark

                            Comment


                            • #15


                              You think its the usb cable? that was going to be my last guess but defiantly a possibility.

                              Attachment Below
                              Attached files usbdevices.txt (68 KB)

                              Comment

                              Working...
                              X