No announcement yet.

Unable to Mount uSD Card

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to Mount uSD Card

    Ok, I read all that I can and this is where I stand. I am using a SanDisk 4GB uSD memory card. I was able to use the RMPET tool to partition it as a 2GB FAT16. I can transfer files to it from my PC. I found the uSDTester tool and ran that. It was successful doing the media_init and showed the following:
    Part# type Start Length
    1 06 00000001 003FFFC0
    2 DA 003FFFC1 00362C3F

    It then tried to mount the disk and it failed.
    The message is "Disk probably not formatted".
    I know it is formatted since I can copy files to it and if I put it back into my PC I can see the files that I had put there.

    Any suggestions?

    Thanks, Joe

  • #2

    There's a bit of a missmatch between what windows will generate as a 'maximum 2gb' card and what the display will accept (mount).

    Try using rmpet again. When it comes up on the card you have previously partitioned as 2gb have a look at the percentage (IIRC it will be 53%).

    Delete the partition and recreate it, this time specifying a percentage and a lower lower one (1% lower will be fine IIRC)

    Remove, reinsert, format and try again.

    Let us know how you get on


    • #3

      Had the very same problem myself last week. Solution was the same. A 4GB PNY and 4GB Transcend reported 53% and 54%. Both failed to mount. By redoing and setting size to 50% both brands mounted fine.


      • #4

        Thanks guys! That did the trick.


        • #5

          I still have that very same problem: I tried the DEMO application from the Samples/Picaso GFX2 directory.
          I prepared a 256MB uSD card, half FAT16, half RAW (using RMPET) and copied all necessary files on the FAT16 partition of the disk.

          When I compile and download the application, I see the menu appearing (with Tetris, Sliders, and so on), but each and every time I see "Mount Failed!" at the bottom of the screen.

          When touching the screen, I see the respective buttons "pressed", for a short time, I see the app title on the location where I saw the message "Mount Failed!", but shortly after, I get again the "Mount Failed!" message that keeps on coming.

          Any idea what else could go wrong?
          Best rgds,


          • #6

            That really sounds like your power supply is marginal, how are you powering the display and what sort of wiring are you using?


            • #7


              I'm powering my module using the USB-to-serial converter µUSB-MB5, which I bought (for warranty purposes) together with the LCD display µLCD-32PT(GFX). Then via a mini-USB to normal USB cable, connected the converter to the PC. That's how the LCD gets its power.

              I have no other extra power supply connected.

              You think the supply delivered from the USB connector on the PC is too low?

              Could this also be the reason that, when I start an application that needs access to the µSD card (like the demo of the sample applications), sometimes the app starts to "flikker" in the sense that it looks like it's restarting over and over again?

              I just tried yet another µSD card and again the same: mounting failure.

              I've also tried to run this small mount test application, but also here without success...

              I'll try another USB port on my PC and see if that makes any difference.

              Will be back shortly with the answer.
              Best rgds,


              • #8

                Well, I must say, extremely good tip!!!
                I've moved to another USB port on my PC and now the mounting works perfect.

                Thanks very, very
                much for this hint!
                Best rgds,