Announcement

Collapse
No announcement yet.

PA6B GPS module

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PA6B GPS module

    Couple of questions about the module:
    1. Do you have or can you point me to the MTK command set to modify the parameters of the GPS unit.

    2. The data sheet states that the rates are 1-5Hz and 10 is available through the firmware - can you please tell me how I can set the module to 10Hz rate.

    I have found some limited commands from this site http://www.flytron.com/pdf/MTK_commands.pdf However if I try to use these

    set the GPS to 10 hz;
    Serial3.print("$PMTK220,100*2F\r\n");

    but even trying to set the following Serial3.print("$PMTK220,100*2F\r\n"); does not seem to have any effect.

    Cheers




  • #2


    You've got the correct command.



    Have you upped the baud rate? There's no way it will be able to do anything if you request a 10Hz update at a low baud rate.



    Have you tried any other rates? (I'm intrigued as to why you want a 10Hz update)
    Mark

    Comment


    • #3


      Hi,

      Thanks for the quick response. I'm looking at using it for getting fix position for a RC aircraft and actually require the higher rate.

      I was trying to send those commands from Arduino, however I now have the unit attached to the MB5 (only using RX/TX). I have tried the MiniGPS program, but if I change a setting and try to commit it I get a changed baudrate failed MiniGPS V1.4. I did download 1.7, but that has no setup facility

      Regards

      Comment


      • #4


        You should be able to use a terminal window to set it no probs.
        Mark

        Comment


        • #5


          But really how fast can the plane go?



          100km/h is about 28m/sec.



          Then there's the 2 odd metre accuracy limit.



          So 1 second updates aint that bad
          Mark

          Comment


          • #6


            I've tried to use the 4D terminal window, converted the string to hex and sent it, without any result. I just have a constant flow of NMEA information coming from the device.

            I have queried the unit using:

            $PMTK490*3F
            and
            get back
            $PMTK590,0,1,4800,0,1,1,1,5,1,0,0,0,2,9600*3B

            Which is as it is actually set.

            If I try to sent
            $PMTK390,0,4,115200,0,0,1,0,1,1,0,0,0,2,9600*37.
            with a response of:
            $PMTK001,390,2*3B
            Which from online polls means that the command is valid, but can not be processed. Other online polls go on to say that the Response from the PMTK490 indicates that there are no saves of user settings remaining??

            From the MTK Manual:
            Packet Type: 390 PMTK_API_SET_USER_OPTION
            Packet Meaning:
            API_Set_Flash_User_Option
            Write the user setting to the flash to override the default setting. Maximum 8 times without erase the chip.

            How can I run out of writes when I haven't been able to write to it and is there a way to override this so that I can write to it when I want to??


            Any Idea's??

            Cheers

            Comment


            • #7


              Sorry missed the other post that you put up.

              Not overly concerned with the 10Hz 5 would be great, however I am really concerned that I am stuck at 4800 baud.

              Regards and thanks
              K1w1

              Comment


              • #8


                I'm sure I changed the baud rate using PMTK251, the doco I found on the web for that does not mention a 'maximum' number of times for that command.



                What rate is the 'constant stream' of data coming at? (try looking for consecutive packets of the same kind with the time in them)



                As I recall at 4800, 1sec updates there is a 'short' delay between transmissions.



                Sorry I can't be more helpful, I don't have one of those chips connected atm
                Mark

                Comment


                • #9


                  If I try issuing the 251 command then I get no response back within the stream and the data rate does not change. If I try to set it from the MiniGPS tool it all I get is a text box stating that "Change Baudrate Fail" - same for the change in the fix update rate, however if I try to change some of the other features - enable RTCM and set its baud rate the changes are accepted, however these settings are not kept over a power cycle.

                  Looking on the Gtop Website there is a lot of conflicting information - the sales info on the device states that it is capable of upto 10Hz and also a buadrate of 115200, (which is what I bought the unit for) however in their FAQ the list the information I posted previously about it not being able to be changed in some units?? - it is a pretty generic FAQ and does state to contact tech support.

                  I'm going to assume that I need to go through 4D systems first??

                  Cheers

                  Comment


                  • #10


                    I'll hopefully be able to try try a few things in the morning and report back.



                    I've always found it weird that Gtop has so much conflicting information, a bit like 'If you don't like that answer, I have others.'
                    Mark

                    Comment


                    • #11


                      thanks for that .. totally agree .. they have a great sales team, but think the tech team is still trying to catch up. i'll eagerly await the results of your testing.
                      thanks

                      Comment


                      • #12


                        I need to email you something. Can you PM me an email address that will accept attachments?
                        Mark

                        Comment


                        • #13


                          Could you please share what was the solution? I have the same problem. For all of the commands I sent, I receive an acknoledge that the command is correct but it cannot be processed....

                          Comment


                          • #14


                            The previous user was trying to change the bause rate, but I don't think this is what you are trying to do.

                            I presume now you are getting some data and you are trying to change some 'setting'

                            Can you fill us in on what you are trying to do?
                            Mark

                            Comment


                            • #15
                              Yes, I'm trying to change some settings, eg baud rate.

                              Currently the communication is via serial interface on 4800 baud. But when I try to change it e.g for 9600 baud with the following command:

                              $PMTK251,9600*17\r\n i get $PMTK251,2*37, which as I know, means that the command is OK, but it cannot be executed and I don't really see why...
                              After sending the command the baud rate stays at 4800 baud of course.

                              I've tried with different baud rates, but the result is the same....

                              Is there a dedicated minimum time, I should wait after switch on the GPS module? Or can we only change the settings after the 3D fix signal is constant low?



                              Comment

                              Working...
                              X