Announcement

Collapse
No announcement yet.

uLCD43-PT: VISI widgets getting cut off at the bottom

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uLCD43-PT: VISI widgets getting cut off at the bottom

    I'm not sure if this is the right subforum; please feel free to move it to the VISI or Picaso 4DGL area if necessary.

    I'm using a uLCD-43PT to create an instrument cluster with four angular meters, a horizontal "progress bar" meter, and a few LEDs (in landscape mode). It's working fine up until I start to add the LEDs, at which point the bottom 20 pixels or so start getting chopped off with a black bar across the width of the screen. It's only the rendered widgets from the .gci that are cut off; text labels can still be printed in that black space. If I remove the LEDs, the black bar doesn't go away; I was only able to get the screen to start behaving normally again by removing the horizontal meter and restarting the IDE a few times (it wasn't very deterministic).

    I still have more diagnosis to go through before I've exhausted my resources, but I wanted to bring this up in case there's something I can learn from the community or team.

    Is it likely that I'm exhausting the device's onboard resources? My .gci file is about 10MB, and the program itself is only a few KB. I tried using #MODE RUNFLASH; no difference (same if I load it to RAM vs. flash). I'm not sure of my IDE or firmware versions, but both are only a week or two old at most.

    Should I be prepared to submit my project files here, or is there anything you folks can suggest in the interim?

  • #2


    Visi is just an addition to Workshop to help produce a graphical 4DGL program quickly and easily, so the 4DGL forum is probably the best place. Hmm, but there is a Visi forum, but it's not specifically for this sort of thing, maybe we need a Visi Programming forum.



    At this point it sounds like there may be something NQR is the way the IDE is handling this particular setup.



    Can you give us some more information about where this black bar is occurring (ie. on the screen, on the display, or both). You can zip up and attach the program for us as well (A Visi program consists of the .4dg, .4dVisi files and the .Imgdata folder and its contents, which may not exist)
    Mark

    Comment


    • #3


      Thanks for the reply!
      The behavior I'm seeing is on the physical device. The VISI form window shows everything fine.
      Attaching the requested files. If it runs the same for you as it does for me, the bottom half of the horizontal progress bar should be obscured by the black box. (I took out the LED widgets since they seem not to be affecting the current behavior.)
      Let me know if this helps repro. Thanks!
      Attached files gauge.zip (3.1 KB)

      Comment


      • #4


        Works fine for me.



        The most likely possibility is the way the uSD card is formatted. If you used RMpet to partition it use checkdsk to ensure the cluster size is no more than 32kb.



        Our PmmCs do not support 64k cluster sizes, so you need to drop the 'Maximum FAT16 Size' %age created by RMPET until you get a 32kb cluster size in Win7. Will be fixed at some stage.



        If that's not it can you tell me which PmmC and Workshop versions you are using?
        Mark

        Comment


        • #5


          It's not the uSD formatting; I had to format it to 32K clusters before it would read any files off it at all.
          I'm using Workshop 3.2.1.4 and PmmC 2.8.

          Comment


          • #6


            Hmm, still works for me.



            Can you try forcing a rebuild of the .GCI and .Dat by pressing Shift-F9 and see if that fixes it?



            If it's still wrong, zip up the .GCI and .DAT and post them here
            Mark

            Comment


            • #7


              Shift+F9 got it to work okay in the configuration I posted; however, as soon as I add another widget (an LED), it screws up again. Doing Shift+F9 again doesn't fix it.
              I've zipped all four files this time in hopes that it will repro on your end. Thanks again for your help!
              Attached files gauge.zip (107.2 KB)

              Comment


              • #8

                Hmm, well I can see that, on your computer Visi has truncated both the 'Fuel Gauge' object and the Led object. It has truncated it as if the uLCD-43PT was only 236 pixels high.



                Again, it doesn't do that on my computer



                The screen layout, form window size, etc., can sometimes affect this (but shouldn't really), so see if resizing the form window bigger fixes this.



                The major thing that effects this is the VISIDISPLAYS.DAT file. it should be dated 7th November 2011 on Version 3.2.1.4



                Playing with the bitmaps in the same folder as VISIDISPLAYS.DAT could also stuff things up, but you wouldn't have done that.



                Maybe a reinstall? (after uninstalling and ensuring the C:\Program Files\4D Labs\4D Workshop 3 IDE folder is gone after the uninstall)



                Hmm, your zip seems to imply you are running under OSx, can you confirm and give some details of that too?
                Mark

                Comment


                • #9


                  Tried a reinstall; same behavior.
                  Ignore the OS X zip; I just happened to use a Mac to bundle up the files. My dev machine is a Toshiba netbook (NB505, 64-bit Atom N455). Don't suppose that might have anything to do with it?

                  Comment


                  • #10


                    It shouldn't, seems like too much of an odd error to be a Netbook thing, but who knows?



                    Can you add a screenshot of what the screen looks just before you try and build it?
                    Mark

                    Comment


                    • #11


                      I'm not sure what exactly you're looking for, but this is what my screen looks like.
                      By the way, I've found that there's also a vertical strip of not-work at the far right, about 6 pixels wide. Also, I can display an image (i.e. a background) that takes up the entire screen, and again text labels can be printed in the bad areas without any problems; it's like there's just a too-small canvas size that the rendered GCI stuff can take advantage of.
                      Attached files

                      Comment


                      • #12


                        Because a picture is worth a thousand words



                        Now I see you are working with the form 'detached', hmm I wonder if you generate it with it detached, I detach my form and generate and voila, same problem as you.



                        So, I guess your workaround is to 'attach' the form before generating and my task is to figure out why that makes the slightest bit of difference
                        Mark

                        Comment


                        • #13


                          I had to "detach" it like that because I couldn't see a way to work with the form in its docked position in this laptop's tiny screen. The 43PT screen has a lot of real estate and I can't seem to scroll around in the docked panel.
                          I'm glad to see we've pinpointed the issue, though! I should be able to workaround it now. (I don't know if I've been able to figure out how to "reattach" or dock the form view, though... the "close" button doesn't do anything. The controls are kind of mysterious.)

                          Comment


                          • #14


                            The controls are 'standard' (and probably a good indication of why you don't often see this sort of thing)



                            Drag it by the title bar and drop it onto



                            a) The title bar of the object inspector to put it 'above' the object inspector

                            b) The 'window' part of the object inspector to put it 'beside' the object inspector
                            Mark

                            Comment


                            • #15


                              The 'outline' changes to show you when it's going to 'dock'
                              Mark

                              Comment

                              Working...
                              X