Announcement

Collapse
No announcement yet.

uVGA Link not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uVGA Link not working

    After loading the MouseDraw demo, uVGALink tool does not open.
    It displays a Comm Error dialog.

    Tried to open VGA Link tool directly, without the WS3 running still same
    error.

    Loaded Picaso-GFX2 -> Picaso-Demo on disk and loaded runDemos in flash
    shut down WS3 and launch vga link, still same error

    How do I fix this?
    I have 3 Micro VGA II cards and 2 CE5 connectors tried with different combination all giving the same issue.
    I know that the VGA cards and CE5 as working as i can load demo as well as change PMMC file

    Regards

  • #2


    uVGA Link 'inherits' the currently selected com port from Workshop.

    So set this to the com port you want to use before starting uVGA Link.

    The tool needs the com port to be specified as a parameter, so unless you know how to do this you wont be able to start it directly
    Mark

    Comment


    • #3


      when i start vga link tool the WS3 has the com port selected (COM 31) and the indicator in WS3 is blue.
      I am assuming that VGS link picks up the above setting automatically?

      Regards

      Comment


      • #4


        Ahh, yes.

        Problem is uVGA Link uses the 'old' way of openning com ports and thus can't handle com ports greater than 9.

        Can you change the come port setting?
        Mark

        Comment


        • #5


          Ok so Com31 is the problem....

          I dont know how to chnage the port number, can you point me to something...that shows how?

          Comment


          • #6


            Thanks. got it to work now..
            Is there any way to fix VGA link to take 2 digit port numbers?
            I don't mind if it is quick & dirty :-)
            Thanks

            Comment


            • #7


              Fire up device manager, click on 'Ports (COM & LPT)', right click on the device you want to change.

              Then click Properties, 'Port Settings', Advanced, then you can change the com port number.
              Mark

              Comment


              • #8
                Is there any way to fix VGA link to take 2 digit port numbers?
                I presume you've downloaded the source?

                Obviously you will need a way to compile it.

                Just change the openning of the com port 'filename' by prepending '\\.\' to it. or maybe that is '\\\\.\\' taking C into account
                Mark

                Comment


                • #9


                  Nope, I tried looking for the source code for VGA link but could not find it.
                  can you point me to the source for VGA link?

                  What do in need for compiling ? microsoft studio?

                  Or maybe some kind hearted chap at 4D could upload the "fixed" version on the website :-)

                  Regards

                  Comment


                  • #10


                    Hi,
                    here is a newer version of UVGALINK.EXE which has the com port fix for
                    ports > COM9.

                    Just unzip it and put the executable in the DEP folder and all should be ok.




                    Attached files UVGALINK.zip (18.4 KB)
                    Regards,
                    Dave

                    Comment


                    • #11


                      thanks.. that makes life a lot more simpler.

                      Comment

                      Working...
                      X