No announcement yet.

TTL camera working at 5V not 3.3V

  • Filter
  • Time
  • Show
Clear All
new posts

  • TTL camera working at 5V not 3.3V


    I have just purchased a TTL camera and I used the following cable to first connect it to the PC and run the test software. This worked fine. The VCC from the cable is 5V. I then disconnected VCC and GND and instead used a separate 3.3V power supply to power the camera. I then tried to use the PC test software to send a SYNCH, but got no response from the camera. Putting a scope on the RX camera pin, I could see the SYNCH signal going in ok, but when scoping the TX camera pin, I saw nothing. Now, I am a software engineer, not too hot on hardware and electronics (but learning!), so maybe this is a stupid thing to try, but I would be grateful for any advice.

    Many thanks

  • #2

    If you have a uCAM529 then you need to use 5v.

    Otherwise I'm wondering if you have disconnected the GND from the serial cable, which you shouldn't


    • #3

      Ah yes, I had disconnected the GND from the serial cable. All working now. Many thanks for your help.