Announcement

Collapse
No announcement yet.

Stange Serial Behavior

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16


    just tried a different uSD card without any luck... The problem persists. Any clue on the dip in the power line seen in the attached traces when the module is first powered up?

    Comment


    • #17


      I thought you were going to try a big bypass capacitor.

      Have you still got your old board? (What's the part number on the 5 legged chip just above the display socket, using the orientation you used on the Pic you posted on the 28/8. On that photo the chip has ~ 33BB written on it)

      The dip is almost certainly that chip 'cranking up'
      Mark

      Comment


      • #18


        I totally forgot to respond to this thread... I've been playing with my screen that's now up and running and trying to move forward with my project.

        I did add a big cap. to my circuit, and all is well. The power dip during power up is much smaller and the screen starts up and is working as it should.

        For what it's worth, I was reading through the data sheet of the voltage regulator that is on the Parallax dev. board I was trying to use, and it looks like the output cap on the board isn't correct. The manufacturer calls for a minimum value of 22pF for the output cap, but only a 0.1 uF cap was installed. With the correct cap, the screen will turn on.

        Thanks for helping me resolve this...

        Brian

        Comment


        • #19


          Got the Same problem
          uOLED 160G1 Rev 1C on my Prototype

          Now i buyed 3 More of the Displays and Got REV 1G

          Display dont Power UP :-( with USB MD5 it Power up.

          And on 1 of the 3 i cannot Load the GFX PMC R22 in.

          Where you but but the cap in? on the TX/RX line ? sorry im not an electronical expert.

          Comment


          • #20


            It's a bit hard to understand what behood was talking about. He seemed be saying that 22pF is greater than 0.1uF, but 0.1uf is 100,000 pF so what he said just doesn't make sense.

            Are you saying one of the displays powers up with an MB5, but not 'some other way'? What is that other way?

            The one you cannot load the PmmC in. What is displayed when you power it up with an MB5?
            Mark

            Comment


            • #21


              Thx for the Fast Replay

              For my first prototype i got an uOLED 160G1 Rev 1C with PMMC 22, and it works perfectly with my current electronic.

              So i buyed 3 more and got uOLED 160G1 Rev 1G and there i have follow Problem:

              2 of them with the USB MB5 are power up correctly can load my SW and flash it with current PMMC 22

              With 1 of them it Power up (see the default SGG loading Screen, "4d Systems...") and on flash to PMMC 22 i got a wrong Errorcode -3 or some strange characters in a Message Box.

              Second problem with my current HW(Not MB5, serial connected with an MAX232 in between and powered), NON of the Rev 1G get powered on with same software and PMMC 22 , Rev 1C Display work correctly.

              What are the Changes between 1C and 1G did it use now more power?

              Thx in advice for the fast response.

              Comment

              Working...
              X