Announcement

Collapse
No announcement yet.

uOLED-160-G2 on DEVBOARD-G1 problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uOLED-160-G2 on DEVBOARD-G1 problems

    Hello,

    I am at a loss as to what the problem is..

    I have been playing with the uOLED-160-G1(GFX) for a few days and I have programmed it with a very basic program simply to show the programme is running then goes to a blank screen.

    It works fine when the MB5 is plugged into it however when I mount the screen and MB5 onto the dev board and switch the board on there is no response.

    The TX and RX jumpers are fitted, there is 4.7V getting to the display and i've check the continuity of all the pins so there should be no reason that I can see for the program not to startup.

    There are no other jumpers fitted and there is no other extrenal power source.

    I've also tried re-loading the PmmC file when mounted to the board and i get the error message "Unexpected response from the display:- 0"

    Does anyone have any idea what i'm doing wrong?


    **UPDATE***

    I plugged in a 9V battery instead of the MB5 and the programme started up. It would implies that there is something going on with the TX/RX pins but I re-tried the MB5 with the TX and RX jumpers disconnected and it still did not start up.

  • #2


    further investigation seems to the uOLED TX is getting pulled high. When I remove the jumper and probe the TX line on the monitor side it is giving nice regular low pulses.



    When I put the jumper back in I can see at regular intervals a tiny change in the voltage level of the same duration at the low pulses which indicates the line is being pulled high by something on the develpoment board but at the moment I am at a loss as to what.



    I have to say i'm rather miffed that I am having to spend lots of time troubleshooting hardware when it should be plug and play.

    Does anyone have any ideas what could be pulling the TX line high??

    Comment


    • #3


      Um, could you post a picture showing the MB5 plugged in to the Devboard?
      Mark

      Comment


      • #4


        The MB5 was correctly inserted on the board I checked the pin outs on both devices before plugging it in. It appears that the board was faulty and it also looks like I wasn't the first person to try and use it judging by the condition and how the equipment was packaged. I have sent it back and bought a replacement board so i'm waiting for it to arrive and try again.

        Comment

        Working...
        X