Announcement

Collapse
No announcement yet.

FAT - No Display Image or Execute Program

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • FAT - No Display Image or Execute Program

    Spent several hours trying and retrying using the uLcd43 in serial mode, and simply cannot get the display image or run program to work using FAT Controller.

    I have formatted the card as FAT16, I have enabled "Unprotect Fat" under the General tab..

    1) Run Program
    I have created a script which can be uploaded and executed using the Script Execution option on the Script Commands Tab, the script appears to run correctly.

    If I rename the script to autoexec.4ds and copy it to the SD card, and power up, the script executes (although appears to stop halfway)

    But If I try to run the script using the FAT tab > Execute Program using filename: autoexec or autoexex.4ds and even by renaming the file to test.4ds it never executes, and the log reports "No response", and thereafter it stops responding to all commands and needs to be reset.

    2) Display Image
    I have used the graphics converter to create a myimage.Gci file, which is copied to the SD Card and inserted in the device, as per the instructions in the GC manual.

    Under the FAT tab, in the Display Image / Icon fat input field, I enter the original name of the converted image myimage.bmp and press the Display Image button. The image is NOT displayed and the log reports Nak.

    So I am not having much luck, all other commands seem to work, I can send and receive data, I can upload a bitmap from the PC to the display no problem, but these FAT commands refuse to run.

    I am sure I am doing something wrong, but I have exhausted all my ideas now as to what that might be !!

  • #2


    What's the brand of the uSD card?

    Can you do a chkdsk of it and include the output here?

    A dir of its contents?

    The FAT Controller log of you trying to execute command and display the image?
    Mark

    Comment


    • #3


      Hi:

      Thanks, the card is KINGSTON SDC4/4GB, here's the dumps:

      ============
      The type of the file system is FAT.
      Volume 4GSD created 10/21/2012 12:38 PM
      Volume Serial Number is F8F2-B704
      Windows is verifying files and folders...
      0 percent completed.
      33 percent completed..
      66 percent completed...
      100 percent completed....
      File and folder verification is complete.
      Windows has checked the file system and found no problems.

      3,904,634,880 bytes total disk space.
      196,608 bytes in 3 files.
      3,904,438,272 bytes available on disk.

      65,536 bytes in each allocation unit.
      59,580 total allocation units on disk.
      59,577 allocation units available on disk.

      ==========
      Volume in drive E is 4GSD
      Volume Serial Number is F8F2-B704

      Directory of E:

      10/21/2012 11:32 AM 2,871 test.4ds
      10/21/2012 03:01 PM 35,328 rpi.Gci
      10/21/2012 03:01 PM 833 rpi.Txt
      3 File(s) 39,032 bytes
      0 Dir(s) 3,904,438,272 bytes free

      ===========
      Version 0.031 [56 00] <01 10 22 FF FF>
      Get Status 0.016 [7A] <D8>
      Control 0.000 [59 08 00] <Ack>
      Display Image Icon Fat 0.031 [40 6D 72 70 69 2E 62 6D 70 00 00 00 00 00 00 00 00 00] <Nak>
      Run Program from MC Fat 0.109 [40 70 74 65 73 74 00] <No response>
      Run Program from MC Fat 0.109 [40 70 74 65 73 74 00] <No response>
      ===========

      After the <No response> the display needs to be rebooted as it will no longer respond to commands.


      Note: If i name the test.4ds file to autoexec.4ds then the script will run as the autoexec.4ds file, so the display is actually reading the disk.

      Comment


      • #4


        For the image you have told it to display rpi.bmp, you should be specifying the name on the uSD rpi.gci.

        For the program you need to include the extension.
        Mark

        Comment


        • #5


          Thanks, yes that helped, the script still only executes half way and the log reports no response when it finishes, but I think that's a different problem.

          The image also displays OK.

          Many Thanks again

          Pete

          Comment


          • #6


            Perhaps you need to post the script, it's quite possible it's trying to do something that can't be done in a 'real' script.
            Mark

            Comment


            • #7


              The script is the sample script Graphics Pt1, when I run this from the FAT controller Script Commands > Script Execution it runs all the way, and finishes by drawing the 4D logo.

              If I run it as autoexec.4ds or execute from FAT it appears to stop at line 47 - String(00,06,03,yellow,"dsiplay Bm Ch") and this is the last thing that is drawn, and the log reports , lines 48 -144 don't appear to be executed.

              Comment


              • #8


                Hmm, yes, there is a bug in DrawUserBitmap* that will prevent its use in a uSD resident script.

                Is this something you really want to do, or is t just for testing?
                Mark

                Comment


                • #9


                  No, I am just testing and getting to know the system and finding my way around at the moment, it's not something I need right now.

                  I have now moved onto the touch commands are are also seeing some odd things with that, although it may be that I misunderstand the functions / responses, I will do more testing first before I ask any more questions.

                  Many thanks for your help

                  Pete

                  Comment

                  Working...
                  X