Announcement

Collapse
No announcement yet.

uVGA-II does not seem to work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uVGA-II does not seem to work

    Hi,

    I have just bought a uVGA-II from TIGAL. After connecting the Vin, TX, RX, GRN, RESET pin to a ARDUINO MEGA, I can get it to display anything on a my VGA monitor. From the manual for SGC operation mode, it says :

    The uVGA-II(SGC) will wait up to 5 seconds with itsscreen blank for the host to transmit the AutoBaud command (âUâ, 55hex). If the host has nottransmitted the Auto-Baud command by the endof this period the module will display a built-insplash screen. If the host has transmitted theAuto-Baud command, the screen will remainblank. This wait period is for those customerspecific applications where the splash screen isundesired.
    From this I understand that even if TX/RX/RESET are not receiving any signal, the uVGA-II should still display the splash screen.

    I have checked the following :

    - 5 volts is properly supplied from the ARDUINO to the uVGA
    - the monitor works in VGA
    - the pins are connected properly

    Could someone please help me with this. Maybe I am doing something wrong. Otherwise it just means the card I got is not working.

    Cheers,
    Eric

  • #2


    Have a look at the screen carefully with just Vcc and GND connected.

    Is there an initial piece of text in the top left corner that dissapears after a few seconds? (as in the GFX splash and not the SGC one)

    Have you got any other VGA type monitors you can try? (maybe that one can't lock this particular signal)

    What about using FAT Controller, can you get a communication going?
    Mark

    Comment


    • #3


      Thanks a lot for the tips.

      I check for text in the left corner but nothing comes up. Tried on a different monitor but got the same result only connecting the uVGA to VCC and GRN.

      I tried to download the FAT Controller - Software Tools but got :Forbidden
      You don't have permission to access /downloads/Software/FAT-Controller/FATcontroller.zip on this server.


      Seems like I am band from the Web site (already ?) or there is a problem on the site.

      Not my lucky day it seems.

      I'll give another go at the download tomorrow.

      Thanks again for the help.

      Eric

      Comment


      • #4


        I tried teh web site just now and it was OK.

        Hopefully you will have better luck when you try again
        Mark

        Comment


        • #5


          Ok I will try again tonight.

          Got some feedback from the 4D Systems support and, when back from work, I will try to use a more powerfull 5V supply to see if it is not the ARDUINO card that is not providing enough power.

          Comment


          • #6


            UPDATE : In the end, the uVGA-II that I had turn out to be faulty. The new one, bought from 4D Systems, works perfectly with my ARDUINO MEGA in SGC mode.

            I got it working a 57600 bauds but when I try 115200 some all Draw Rectangle commands gets lost but "Draw ASCII Character (graphics format) - 74hex" command works. Weird !!!

            I'll stick to 57600 bauds for now.

            Comment

            Working...
            X