No announcement yet.

Problem writing file with uLCD-43P(SGC)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem writing file with uLCD-43P(SGC)

    I have your uLCD-43P(SGC) unit and I am trying to write a file, using the FAT system, on a 2 gig memory chip. I am copying the example given on page 75 of

    I am matching the data given in your example.

    My C program sends the first block of data over the serial port (with the file name, etc. given in your example) and your display responds with an ACK. Then I send the 25 byte data block given in the example, and your unit again responds with another ACK. At this point, I am assuming my file should have been written on the memory chip.

    I take the 2 gig memory chip out of your unit and insert it into my PC. The file has been created and the name is correct, but the data length is zero bytes!

    What am I missing? Do I need to close the file somehow before I remove the chip?


  • #2

    Don't know, I would think if you were sending it exactly as per the example then it would work.

    It would appear that the display is expecting more data and therefore hasn't yet closed the file.

    Can you use FAT Controller and send the same file, noting the exact exchange?

    If you are still having problems, cn you post the exact exchange here?


    • #3

      I will order a programming cable and give it a try. I will respond here after I get the results (a couple of weeks).



      • #4

        I got the cable. I installed the driver. I am attempting to run the FAT controller program.

        I get the following error message:

        "Version command response does not contain resolution information and no valid 4DRom image loaded"

        I do not the screen with the tabs that is shown in the FAT controller documentation.

        Now what? How am I supposed to use this program to diagnose my problem?



        • #5

          On the downloads tabe of product page there is a download for 'stimulation files'.

          Download the file for your display.

          Click settings in FAT Controller and aim the ROM image at the file you just downloaded.

          Try the open again


          • #6

            This is my display

            What is the link for the simulation file?



            • #7

              That's the GFX product page.

              It's on the downloads tab of the SGC product page


              • #8

                How do I know which one is for my display?


                • #9

                  Not knowing which simulation file to use, I just picked the first and ran a test. Although I couldn't duplicate my results precisely, the FAT controller can not write a file with this display either. I tried all the options.

                  I don't think the FAT code works correctly in this display.

                  Can you test one of these at the factory?



                  • #10

                    The 43PT files are probably 'more' correct for you, the extra letters refer to the screen orientation, L(landscape), P(portrait) and R(reversed). The file that has nothing is the 'standard Portrait' file.

                    All displays are chjecking in the factory before shipping, so yours should work, bar damage during transit.

                    Can you post the FAT Controller log here, so we can see exactly what you are doing?

                    Have you tried a different (make/model) of uSD card?


                    • #11

                      Thanks for your help! It was a combination of problems.

                      I had to do a low-level format on the uSD card. That made your FAT program work.

                      I had an error in my code. Everything was fine after I copied the trace from the FAT program.

                      Thanks again,