Announcement

Collapse
No announcement yet.

uCAM TTL - PACKAGE SIZE

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • uCAM TTL - PACKAGE SIZE

    For info, I have used the uCAM TTL to take JPGs of different resolutions and am able to view them on my PC - which means that my software works. However, I cannot set the PACKAGE SIZE to be larger than 64 decimal. If I do, then I still get 64 byte packages. I am using the OV 528 chip.

    Any ideas why this would be the case?

    I can set different package sizes as long as they don't exceed 64 bytes.

    I know that package sizes are meant to be even and not multiples of 16 - which raises another question - Why do the examples in the documentation show SET PACKAGE SIZE commands of 512 bytes, i.e. a multiple of 16. Shouldn't the maximum be stated as 510 if it is not meant to be odd or a multiple of 16?

    The following command works for me:-

    0xAA, 0x06, 0x08, 0x38, 0x00, 0x00


    Any ideas would be much appreciated.
    Gwae fi fy myw mewn oes mor ddreng.

  • #2


    More information about my problem.

    Here is the sequence:-

    Got sync OK INITIAL (jpeg 160 x 280)0xAA,0x01,0x00,0x07,0x07,0x03 Reply OK0xAA,0x0E,0x01,0x01,0x00,0x00 SET PACKAGE SIZE = 120 bytes0xAA,0x06,0x08,0x78,0x00,0x00, Reply0xAA,0x0E,0x06,0x02,0x00,0x00 SNAPSHOT0xAA,0x05,0x00,0x00,0x00,0x00, Reply0xAA,0x0E,0x05,0x03,0x00,0x00 GET PIC0xAA,0x04,0x01,0x00,0x00,0x00, Response0xAA,0x0E,0x04,0x04,0x00,0x00Response0xAA,0x0A,0x01,0xEC,0x0F,0x00 Size of the image = 4076 HOWEVER Even though I have set package size = 0x78, I only ever get 64 bytes back So there is missing data. When I set package size = 0x38, then there is no problem and I get the whole image back (I can view it). Any idea what is going on?
    Am I missing something obvious?
    Gwae fi fy myw mewn oes mor ddreng.

    Comment


    • #3


      Can you reproduce this problem with the uCam demo program?

      I've tried with my uCAM module and it works fine for 120 byte packet sizes, but maybe your uCAM model is different.

      Can you check with the demo program and if that works look for problems with your code?
      Mark

      Comment


      • #4


        Thank you for replying.

        Just after you replied I though of the solution.

        I managed to find that my Arduino had a RX buffer size of 64 bytes - hence the limitation.

        I have now changed that value in the header file, and I am now able to receive many more bytes in each response.

        Mystery over.
        Gwae fi fy myw mewn oes mor ddreng.

        Comment


        • #5


          i have 2 uCAM-TTL too and i bought them for my master thesis. but they aren'T responding to SYNC commands and my time is passing. i tested them with special equipments in a company and they said they r not working. it seems i threw my money to the garbage. what do u suggest? should choose another camera? or is there any chance that they will work? i'm desperate now.

          Comment


          • #6


            A 4 way cross post, please don't
            Mark

            Comment

            Working...
            X