Announcement

Collapse
No announcement yet.

Issue when selecting lines with mouse then using TAB to indend

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue when selecting lines with mouse then using TAB to indend

    After selecting several lines in the editor, if the TAB is ussed to increase the indentation this can happen:

    - the first line above the selected lines is also indented
    - the last selected line is not indented

  • #2


    A line is considered selected if the 'end' of it is selected. The 'end' is actually the invisible newline character at the end of the line.

    So to select a range of lines with the mouse, select from some part of the first line to a part of the line following the range (or just the start of if you you want)
    Mark

    Comment


    • #3


      Still there are non-selected lines (above or below) that gets indented.

      Comment


      • #4


        Huh?

        Can you post some sort of example?
        Mark

        Comment


        • #5


          File : R_INSANE.4GL

          See before an after pressing TAB screen shots. Attached files

          Comment


          • #6


            Was there some special trick involved?

            If I open WS4, then R_INSANE.4DG, select the area indicated in the first snapshot with the mouse and press tab, only the

            LEFTCOLOUR 0xF800

            Line gets indented
            Mark

            Comment


            • #7


              I think you have an old version of workshop PALYGAP. What you showed in your pictures is exactly how mine used to work, but I just updated to version 4.0.2.7 and it acts like ESPsupport says now.

              Comment


              • #8


                In WS4 it says 4.0.2.7. I use Windows XP Professional and WS3 was installed before. Did not do a WS3 uninstal before installing WS4 but put it in a different directory.

                Weird indeed. Thanks ipaq3115 for confirming the behaviour,although in previous version. Could be I would have uninstalled before installing again to make sur components, DLLs did not get mixed up (just in case).

                Comment


                • #9


                  Yeah, that is weird. I didn't uninstall my old version before I installed the new version, but I am on Windows 7 so that could have been the reason they acted differently.

                  Comment


                  • #10


                    Yes maybe. I'll have to move to windows 7.

                    Comment


                    • #11


                      Hey, I'm having the same issue, I'm running Windows 7 and I didn't uninstalled the WS3.
                      Also when I shift tab is removing the tab on the line before my selection.

                      There is a workaround to this? maybe uninstalling WS3?

                      Another weird behavior is redoing or undoing stuff, the far I get undoing the worse.
                      It mixes the old code with the new code and if you try to redo it mixes the undo with the redo with the existing code, it's just crazy.
                      --
                      JM

                      Comment


                      • #12


                        Yeah, I thought that the tab behavior had changed in the new version of workshop but mine is still working the same, not sure why I thought it was changed. I've gotten pretty used to it though.

                        I have to second the part about the undo redo functions screwing up. I hadn't mentioned it to any of the 4D guys though because I can't seem to consistently recreate it. Just seems to be random. Very annoying though. Another good reason to save a copy on every save and save often (Just in case you didn't know workshop had a setting to do this now, so if undo messes stuff up you can just return to your last save.)

                        Comment


                        • #13


                          Good tip, where is that setting?
                          --
                          JM

                          Comment


                          • #14


                            It's just in there with all the other options. Look on the left in the file menu for the options.

                            File > Options (4th from the bottom) > Backup Files when saving

                            Comment


                            • #15


                              Got it, thanks!
                              --
                              JM

                              Comment

                              Working...
                              X