Announcement

Collapse
No announcement yet.

Issue when selecting lines with mouse then using TAB to indend

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16


    Unfortunately the undo/redo problem has always been there.

    Until someone twigs as to how to recreate it at will so we can get a handle on what causes it there's not much that can be done, sorry.
    Mark

    Comment


    • #17


      Yeah I understand that, sadly mine is always doing that so I choose not to use the redo or undo feature, if there is something that I can do or any information that I can give to you just let me know.

      if WS4 has some debug mode that I can run for you let me know.
      --
      JM

      Comment


      • #18


        I understand what you are saying, but 'always'?

        I haven't seen it make a mistake for me in at least 2 months.

        Maybe you do the 'magical' something that triggers it more frequently.

        Please try and use it to help trap the trigger.

        Once you hit it, you know it's time to restart workshop and if you have backup files turned on, you should be able to quickly 'undo' any 'saved' corruption.

        BTW WS3 and WS4 are totally separate as far as the executables are concerned, there's no 'shared Dlls' or such
        Mark

        Comment


        • #19


          I have it happen every week or two, but I've never been able to figure out what causes it. I still use the undo/redo a lot, just have to live with loosing whatever I was working since the last save.

          JM, would be interesting to know if the undo ever works for you. Because if it does work some of the time it might be easier for you to figure out what you have to do different to make it fail or make it work.

          Comment


          • #20


            I think that the problem might be when I do some copy an paste functions and then try to undo, I notice that when things start to get ugly one of the undo function do something at the top of the document like positioning the cursor there for some reason.

            I will take a look more closely and post here some step by step guide to reproduce.
            --
            JM

            Comment


            • #21


              Yeah, I've noticed the weird cursor jump to the beginning of the file after hitting undo but I can't seem to make it mess up when it does that.

              Comment


              • #22


                I found a way to reproduce the first issue, with indenting. If I select some lines using the keyboard from top to bottom (using cursor-down), and then press tab, all is good. But if I select from bottom to top (using cursor-up), two extra lines get indented. Same thing happens when using the mouse.

                Hope that helps on fixing this.

                Comment


                • #23


                  Thanks for that, we'll see if we can solve it.
                  Mark

                  Comment

                  Working...
                  X