Announcement

Collapse
No announcement yet.

uSD cards will not mount.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uSD cards will not mount.

    I compiled an old program using the new Workshop4 IDE and PmmC 3.3.

    This program used to mount all of my uSD cards with no problem. Now only one (an unnamed and very fast uSD card) will mount. None of my HP or PNY cards will mount. All cards are 2GB.

    The media_Init() command works ok but file_Mount() does not.

    Power to the display is good and the program is unchanged from the 'PmmC 3.2 with Workshop 3 IDE' version where this problem did not occur.

    Any suggestions would be appreciated.

    Thanks.

  • #2


    Further information...

    I tried many things to get the cards to mount and finally came upon a work around.

    If RMPET.exe is used to create FAT and RAW partitions on the HP and PNY cards they will mount.

    I did not have to do this before, the one card I had that always worked has only a single FAT partition which fills the entire uSD card.

    Comment


    • #3


      Hmm, I just tried an unpartitioned 2gb card and it monted just fine.

      Could you find another card that doesn't work and do a few things on it?

      Chkdsk and include the output here

      RMPET to display its setup and include the screen here
      Mark

      Comment


      • #4


        Today all of my cards work. I can't explain it.

        The only way I can get them not to work is to clear the boot sector. But the cards I tried yesterday were definitely formatted and had many files on them.

        I have tried clearing the boot sector then using mkdosfs to format the entire card as FAT. I also tried RMPET to make 100% FAT and 50% FAT/ 50% RAW. I used mkdosfs on the FAT partitions. I even tried formatting in Windows XP and everything mounts fine.

        Sorry about that!

        Comment


        • #5


          Even more spooky
          Mark

          Comment

          Working...
          X