Announcement

Collapse
No announcement yet.

Problem with gfx_GetPixel(n,n);

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with gfx_GetPixel(n,n);

    Using an older model uLCD-144 for development and Workshop4. Using a gfx_PutPixel(n,n,RED), followed by a gfx_GetPixel(n,n), as shown in the Internal Functions manual. The gfx_GetPixel() does not return the 16-bit color code for RED as documented. Is there any sort of fix or workaround for something like this?

  • #2


    Please disregard this post. Whatever I was doing wrong I corrected at some point. All working fine now. No clue what I was doing. Hate it when that happens.

    Comment


    • #3


      Please disregard my request to disregard. This IS still a problem.

      The attached program demonstrates the problem. Numbers are being returned, just not the color for the pixel at the center of the screen.


      Attached files Demo.4dg (970 B)

      Comment


      • #4


        This has been fixed and a new set of PmmCs will be released soon (hopefully in the next week or so)
        Mark

        Comment


        • #5


          Thank you kindly. I will be watching for it.

          Comment


          • #6
            If I ignore this and try to upload the Designer 'Hello World' code I get a 'Target incompatible' error. I've tried loading and reloading different PmmC drivers to the displays but nothing works. I also get the exact same error on two separate laptops/uOLEDs/4D programming cables so it's not hardware. Feels like a newbie error but I can't work it out. Please help.











            ____________________________________________________________________
            Last edited by Lala22; 20 March 2015, 03:59 PM.
            kaleem

            Comment


            • #7
              Why didn't you place this in a new thread? I'd move it for you except I'm not sure where to put the post.

              The target incompatible as a few more lines of text that explain the error, and if the display was connected when workshop was started Workshop would offer to fix the problem for you.

              Can you tell us what display you have and what the full text of the message is?
              Mark

              Comment

              Working...
              X