Announcement

Collapse
No announcement yet.

Slight Image Corruption/Wrapping Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Slight Image Corruption/Wrapping Issue

    I'm having some strange problems with my two SGC OLED displays (160 G1 and 128 G1). I'm communicating with them over serial with an Arduino mega at 9600 baud and encountering a wrapping issue. I should note that I can communicate and send other commands (text, lines, shapes etc.) just fine, but whenever I send an image or video command the proper image/video displays but is slightly warped in that the rightmost 3 pixel columns are displayed on the left side of the image and switched with the rightmost. For example if I want to display an image like this (this is just a test to clearly show the error and not one of my 'real' images):



    I'll get this instead:


    This error happens on both displays. I've triple checked on multiple different images that the bit depth is correct (all 16 bit bitmaps) and the serial commands are correct. I've used 3 different fully formatted microSD cards and the issue is always the same. Anyone have an idea what might be happening and how I can solve this? Attached files

  • #2


    When you create an image in GC you should select the last option (SGC - uSD RAW).

    If you select the second option you will get an image that looks very much like that.
    Mark

    Comment


    • #3


      Oh man, shoulda known. Thanks! Works great now

      Comment

      Working...
      X