Announcement

Collapse
No announcement yet.

uTOLED - SPE - Display Image (RAW)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • uTOLED - SPE - Display Image (RAW)

    Hi,

    I'm using this new transparant display, and the Serial Environment Command Set. I can't get an image to display. I'm using a uSD card which has images created using Graphics Composer. The uSD card worked in my uOLED-160-G1, but I notice the the Display Image (RAW) command doesn't specify the image size. I have used Media Init and Set Sector Address.

    Any ideas?

    Dave.
    Don't dispair - you'll get there!!

  • #2


    What version of Workshop are you using?

    You will need Workshop 4.0.2.12 for that to work properly.
    Mark

    Comment


    • #3


      Yes, that's the version I'm using. Graphics composer version is 3.0.0.28.
      Don't dispair - you'll get there!!

      Comment


      • #4


        Sorry, was a little bit confused there.

        You specified the image size when you created the image.

        If you position it in such a way (or it is so large) that it exceeds the displays boundaries then 'anything can happen' as regards what displays, you may get a partial image, a garbage image, or no image.

        If the image works on the 160 and is sized correctly to also display on the Toled, then it should work just the same.

        Do you have the latest Toled PmmC installed in it?
        Mark

        Comment


        • #5


          I have the latest PMMC installed. I then used SPE load in Workshop 4. The images were created at an earlier date using Graphics Composer. I have tried sending commands via Serial Commander - this works fine. Using Serial Commander, I have tried changing the orientation of the display - also works fine, but no orientation will show the images. I notice that the Serial Commander command for displaying an image doesn't ask for image size. Could this be the problem? That the command doesn't know where the image ends and is just trying to copy the whole card to the screen?

          Am I supposed to use a different setting in Graphics Composer for this display/using the serial command set? When I was using the old oLED screen, I was using the Goldelox serial commands which are different.

          Dave.
          Don't dispair - you'll get there!!

          Comment


          • #6


            Here's my Graphics Composer files...

            Attached files ASE_OLED.zip (5.6 KB)
            Don't dispair - you'll get there!!

            Comment


            • #7


              I notice that the Serial Commander command for displaying an image doesn't ask for image size. Could this be the problem? That the command doesn't know where the image ends and is just trying to copy the whole card to the screen?

              Am I supposed to use a different setting in Graphics Composer for this display/using the serial command set? When I was using the old oLED screen, I was using the Goldelox serial commands which are different.
              Ahh, you were using Goldelox SGC before. Now you are using 4D Serial.

              When you saved the images to the uSD orignally you used the 'SGC - uSD Raw' option. 4D serial uses a mre sophisticated technique, you need to resave as '4DGL- uSD Raw....'.

              The first two images in your GCI need shrinking to fit on the display.

              Goldelox can only display images in their 'native' orientation, this differs between the 160 oled and the Toled, so you may need to rotate the images if you want them to appear to show in Landscape on the Toled.

              You can get Workshop to do that for you, I have descibed how in the forums a little while ago, yell if you want to do that and can't find the post.
              Mark

              Comment

              Working...
              X