Announcement

Collapse
No announcement yet.

High baud rates on uTOLED-20-G2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • High baud rates on uTOLED-20-G2

    Hi - I am using a uTOLED-20-G2 with the 4D programming cable. I can communicate up to 115200 but if I try anything higher, I get a message in Workshop4>SerialCommander that says "CP201x Baud rate Configurator (AN205SW) needs to have been run..."

    The current (March 2013) SiLabs website does not make any mention of AN205SW. There is however an AN721SW that does baud rate configuration. When I tried that, it finds the programming cable but is not able to change the baud rate. (see attached screenshot)

    Am I doing something wrong? How do I increase the baud rate?
    Jon. Attached files

  • #2


    Hmm, yeah, doesdn't work for me either, even with the latest drivers.

    They have an archive of AN205SW on their site from 2008, but that version doesn't work either.

    We have put the 2011 version of AN205SW that does work on our product page http://www.4dsystems.com.au/prod.php?id=138
    Mark

    Comment


    • #3


      OK thanks, that version of the software works. Thanks for putting it on your website.

      Can you talk me through how to get a module running at a higher baud rate though? I can't get any comms. This is what I'm doing:

      1. Set the baud rate to 500,000 using the AN205SW app. Exit.
      2. Load Workshop4. Set the default serial environment initial baud rate to 115,200 because you can't set it as high as 500,000.
      3. In Serial Commander, try to connect at 115,200 baud. It seems to connect OK, but I get no response to any command. I've also tried connecting at 500,000 - again no response. In fact, I can't get it to respond at all any more, at any baud rate.
      4. The only thing I can do is go back to the AN205SW app and set the default baud rate back to 115,200, then I can re-connect in Serial Commander.

      What am I doing wrong? Could you outline the process for me?
      Many thanks,
      Jon.

      Comment


      • #4


        The CP2102 sets the 'actual' baud rate based on a 'range' passed to it.

        For example if a Windows program requests a baud rate anywhere from 77609 to 117028 baud the CP2102 will communicate at 115200 baud.

        From the Goldelox SPE baud rate table we can see that 256000 baud is actually 255000 baud. The CP2102, by default will, if 256000 baud is requested set the baud rate to 256000, which wont work. So you need to set the range for 254235-273077 to be as close to 255000 as we can. So double click on that entry and type 255000, it will set the rate to 255319 which will work fine, click OK and then Set configuration.

        If you then reload the SPE with the default baud rate set to 256000 it should communicate just fine.
        Mark

        Comment


        • #5


          OK, I've got it. Basically you need to:
          1. Change the baud rates in the CP2102 so they match the Goldelox processor rates
          2. Set the default so something low-ish (like 115200), and do SPE load
          3. Open the port at 115200, then change to the high baud rate.

          Many thanks. I'm working on a set of LabVIEW drivers for the Goldelox-SPE. Now coming along nicely.
          Jon.

          Comment


          • #6


            A related question...

            In SerialCommander, I start with baud rate of 115200. I then switch to 500000 baud, then back to 115200. This is what I get in the window...

            blitComtoDisplay will not work above 375000 baud without pacing
            CP210x Baud rate Configurator (AN205SW) needs to have been run to set
            range 491521-567138 to 428571 for communication to work
            setbaudWait[000B 0006] 0.102 (ACK)

            setbaudWait[000B 0019] 0.102 (ACK)


            My question is:
            Why does changing to 500000 baud send 000B 0006, and why does changing to 115200 baud send 000B 0019.

            From my reading of the Goldelox instruction set, it ought to be:
            000B 0012 (index 18, for 500000)
            and
            000B 000D (index 13, for 115200)

            I'm struggling to get my application working and I wonder if this has something to do with it. Any ideas?
            Many thanks,Jon

            Comment


            • #7


              Ouch The manual is completely wrong with the numbers it uses to signify the baud rates.

              The numbers you see Serial commander using are correct.

              We'll get that fixed ASAP, the numbers should be

              BAUD_110 27271
              BAUD_300 9999
              BAUD_600 4999
              BAUD_1200 2499
              BAUD_2400 1249
              BAUD_4800 624
              BAUD_9600 312
              BAUD_14400 207
              BAUD_19200 155
              BAUD_31250 95
              BAUD_38400 77
              BAUD_56000 53
              BAUD_57600 51
              BAUD_115200 25
              BAUD_128000 22
              BAUD_256000 11
              BAUD_300000 10
              BAUD_375000 8
              BAUD_500000 6
              BAUD_600000 4
              Mark

              Comment


              • #8


                Hello

                The document has now been updated to correct this mistake

                Please download the new revision from the Workshop 4 product page on the website, http://www.4dsystems.com.au/prod.php?id=172

                Regards
                James

                Comment

                Working...
                X