Announcement

Collapse
No announcement yet.

uLCD-xxx programming

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • uLCD-xxx programming

    Hi,

    We use a quantity of uLCD displays and currently program these using Workshop 4.
    The fear is we have to load the current source code into the workshop in order to compile and download the firmware. Is there any way we can download pre-compiled files without having to load the source files, this is so I don't have to worry about other people possibly corrupting the source files...

    Regards,

    Zera

  • #2
    Have a look at

    C:\Users\Public\Documents\4D Labs\SCRIPTS\4DGL\LOAD4DGLPROGRAM.4DSCRIPT
    Mark

    Comment


    • #3


      Hi ESPSupport,

      Thanks for the script, how do I execute the edited version?

      Cheers,

      Zera

      Comment


      • #4

        I found the scriptC.exe

        With my 4XE file pre-compiled for my display "uLCD-43PT" I get this error trying to load to flash.
        "C:\Program Files\4D Labs\4D Workshop 4 IDE\DEP\scriptC" LoadProg /ccom10
        No Errors, code size = 19 bytes
        Starting Script LoadProg.4dscript
        Opening COM10 Speed=115200 baudCommPort Closed
        Please recompile with correct platform settings or use a uLCD-43PT platform.
        ABORTING Script LoadProg.4dscript

        ...any ideas?

        Comment


        • #5


          Can you paste part of the workshop4 screen, showing the comms tab and the source showing the #platform statement?
          Mark

          Comment


          • #6


            Hi,

            ---//---
            #platform "uLCD-43PT"
            ---//---

            Photo attached. Attached files

            Comment


            • #7


              Could you check that you are using the latest workshop? (although the only bug of this type was in 4.0.2.7 which is quite old)

              If you are still having issues could you post the contents of the yourprogramname.cfg file?
              Mark

              Comment


              • #8


                Hi,

                Workshop version used = 4.0.2.7!!

                I'll update my version and try again...

                Cheers,

                Zera

                Comment

                Working...
                X