No announcement yet.

uCam not responding

  • Filter
  • Time
  • Show
Clear All
new posts

  • uCam not responding

    Hi everyone, I need help with my uCam JPEG TTL ~

    I am having this problem of synchronizing the camera with my Arduino Duemilanove Mega328 as I kept receiving

    Sync [AA 0D 00 00 00 00] Response Missing.

    I'm pretty sure that something is wrong but I'm not too sure where could someone please enlightened me? ^^ Tyvm in advance The connections to the Arduino from the JPEG TTL are correct. It seems like the baud rate between the Cam & Arduino isn't matched..

    Or is it that there should have some program in my setup?

    I compiled my Arduino code as

    void setup () {}

    void loop ()

    Attached files code.txt (3.2 KB) code_1.txt (699 B)

  • #2

    Um, how do you get that message if you have no setup and no loop code?


    • #3

      Oh, I'm so sorry, I got confused with it. Anyway, I tried compiling with this code

      [i][b]#include [i][b]#include [i][b]JPEGCamera camera;[i][b]void setup ()[i][b]{[i][b] camera.begin(115200);[i][b] Serial.begin (115200); [i][b]} [i][b]void loop () [i][b]{int data=0, j=0; [i][b]while(j


      • #4

        Have you check the sync command that you send on an oscilloscope?

        Checked the timing diagram, I had the same problem when I use software serial.


        • #5

          That still doesn't make much sense, it looks like you are writeing the response from the camera to the camera

          Where did JPEGCamera.h come from?

          I am not aware of one having been written for our camera and the ones I can quickly find on the net will not work with our camera


          • #6

            @HH75 Nope, I haven't. Perhaps, I'm trying that later.

            @ESPsupport Oh, because I was following the commands of sending command to camera & reading data sent by camera to Arduino from here

            And, the JPEGCamera.h is one of the file in my library as to declare JPEGCamera camera; . If the header #include is not included, I could not compile it and giving an error saying that JPEGCamera does not name a type.


            • #7

              The camera for which that library was written has a completely different command set to ours.

              You may be able to adapt it with some effort, but I haven't really looked into it.