Announcement

Collapse
No announcement yet.

drive not mounted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • drive not mounted

    Hi, im new at this. I just bought a uLCD-32PTU display and im using the visi-genie environment to program it, every time i download a program to the display it only shows "drive not mounted..." i cant get it out of there.

    Thanks

  • #2


    Hi Pablo,

    We have just replied to your email,
    uLCD-32PTU module with ViSi Genie Environment requires a uSD card to have the resources saved in to it. Workshop would have prompted to copy some files to the uSD card when you would have compiled your ViSi Genie program? If you copy those files to a FAT (aka FAT16) formatted uSD card by selecting the drive and pressing OK, later insert the uSD card in to the module, you shouldn’t get that message. SemiHidden="false" UnhideWhenUsed="false" Name="Medium Grid 1"/> olorful Grid Accent 4"/> ity="33" SemiHidden="false" UnhideWhenUsed="false" QFormat="true" Name="Book Title"/>

    Are you using a FAT (aka FAT16) formatted uSD card? Please confirm.

    You may wish to refer to the ViSi Genie related documents on the 4D Workshop4 IDE page for further details.
    -Bilal

    Comment


    • #3


      Im using a sandisk microSD on FAT16 but when i doqnload the files to it and insert it to the display the "..." message blinks faster

      Comment


      • #4


        Hi Pablo,
        There could be different reasons for a uSD card not responding.

        -The uSD card should support SPI: PICASO communicates with the uSD card through SPI. You may wish to check out the following thread and try the program attached to see if you get anything back from the uSD card.
        http://4d.websitetoolbox.com/post/Not-All-uSD-cards-support-SPI-5067632


        You may wish to read this article about the duplicate (fake) uSD cards in the market.

        http://www.bunniestudios.com/blog/?page_id=1022

        -Weak power supply: Which USB to Serial Converter are you using? Could you check the voltages across C22 which the capacitor next to U5 regulator? It should be stable 3.3V.

        You may also try and insert the uSD card loaded with the files and power/reset the module, see if the uSD card works.

        -Bilal

        Comment


        • #5


          Hello,

          I have trouble with exactly the same issue.
          I'm using a sd-card which is working with 4D-displays in SGC-Mode.

          When I tryed ViSi-Genie I also got the message " ..." blinking an the screen.

          Comment


          • #6


            Hello everyone, I have a problem with my display uLCD-28PTU roughly similar to Ptorto. I try to set an image with a small text on my display with a micro-SD card. But when I do the programming, the display continues to show me "Drive not mounted." And when I put the SD card into the display, the flashing message more quickly. I did a lot of research, I don't think the problem is with my SD card because I can save and delete files on it. Perhaps it comes from the Driver or cable programming? If anyone can help me please? Thank you for your attention.

            Comment


            • #7


              Would you care to share with us the details of your research?

              What did the uSD Tester program at Q1 here http://4d.websitetoolbox.com/post/usd-card-and-display-modules-5149940 say? What happened when you did what it recommended?

              What happened when you ran the Cardinfo program from here http://4d.websitetoolbox.com/post/not-all-usd-cards-support-spi-5067632 ?

              What PmmC are you using?

              What make / model / capacity card are you using?

              What happens when you try a different make / model / capacity card?

              And please, you only need to post / email ONCE. So far we have recorded you bringing this to our attention in SIX different ways. It is not appreciated.
              Mark

              Comment


              • #8


                Hello, I'm sorry for all the posts that I wrote, I was not sure it worked. Regarding my program, at the moment I just want to display an image on my screen. So I applied to the letter tutorial 4D-AN-P4005 programming of your website. So I made programming Visie Genie. I downloaded the image on the display Workshop, my micro SD card brand Verbatim 8GB FAT32 formatted (impossible to do FAT16) And finally I press the button "Build" to save the program on my SD card. I downloaded successfully, but when I insert it in my display, the message "Drive not mounted" continues to show flashes faster.
                I make this programming under Windows 7

                Thank you for your attention. cordially.

                Comment


                • #9


                  my micro SD card brand Verbatim 8GB FAT32 formatted (impossible to do FAT16)
                  You need to format it as FAT16, it will never work formatted as FAT32.

                  Read and follow app Note P1001, you need to partition your uSD card so that the first partition is no more than 4GB, then you will be able to format it as FAT16.
                  Mark

                  Comment


                  • #10


                    The problem was indeed my SD card, thank you, FAT32 formatting does not work. So I had to format my card RMPet. FAT16 programming works perfectly: the image appears on the screen. I have another question; I wish to display an image on my screen as I did previously. But I'd like to show another image when an electrical pulse is sent to my display.
                    It is possible ? Thank you for your help. Cordially.

                    Comment


                    • #11


                      The pulse can be used as a 'Pin Input' to change the current form, so if you have two different forms, both with images on it you can achieve that effect.
                      Mark

                      Comment


                      • #12


                        I started in this type of programming, I tried to apply the notes 4D-AN-D4009, replacing led by the image. But it does not work. Do you have a solution to my problem? Thank you. Cordially.

                        Comment


                        • #13


                          Well, You need to describe what you are trying to do in more detail. (maybe post what you think should work but describe how it isn't working and/or what it needs to do to work)

                          Did you get the samples in D4009 working.
                          Mark

                          Comment


                          • #14


                            Hello,

                            I tried to program when there is an electrical pulse using your notes 4D-AN-D4009.

                            Only I have 2 problems:

                            - The Pin PA0, PA1, PA2 .... do not exist.

                            - When I run the program on my display, the LED does not light up when I press the button.

                            I then tried the program I wanted, that is to say an image change when an electric pulse occurs.

                            But when I download my program on my micro SD card, and I put my SD card into the display, nothing is displayed.

                            I guess my programming is false.

                            Do you have a solution for my problem?

                            Thank you for your attention.

                            Bests regards.

                            Comment


                            • #15


                              The Demo is for Diablo which has different pin names from Picaso.

                              I downloaded the demo and changed the pins to IO1_Pin, IO2_Pin and IO4_Pin and the program worked correctly as far as I could see.

                              I also wrote the attached sample that displays Form0 when IO4_Pin is high and Form1 when IO4_Pin is low, which is what I think you are after
                              Mark

                              Comment

                              Working...
                              X