Announcement

Collapse
No announcement yet.

Can't use Mapped Drive

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't use Mapped Drive

    Hi,
    As an introduction to the uOLED-128 and its capabilities I have tried the CoolGauge demo.
    So after an initial confusion about whether the uSD card should be in the display or in my computer (my fault, I didn't read the document properly) I have compiled the program and reach the "download" bit.
    I currently have the screen that says "Copy C8XN18~H.gci to Drive G windows is showing the circling mouse icon to say it's busy and the top bar says "Copy Confirmation (not responding)".
    It has been like this for 15 minutes, is this normal?

    I am running under Windows 7, the uSD disk is a 32G device but I repartitioned it using your program to 1.5G.
    What is the maximum size of uSD card that I can use?

    Philip
    PS: OK while I was writing this email the Copy Confirmation box appeared to finish but with a message to the right of the Drive menu box reading "Error A device attached to th" but I can't read the rest because it has disappeared off the dialog and I can't make the dialog box any bigger to see what it says. None of the buttons work and clicking the X to close the dialog box results in that Windows message box saying "Workshop 4 is not responding".
    Any suggestions as to what I have done wrong?

  • #2
    Goldelox uses unformatted uSD cards, so there is no need to repartition it as any such information will be overwritten.
    You can use any SD or SD-HC card
    Newer versions of windows can report 'not responding' a bit overzealously. Have a look at the size of the GCI file and think about how long it would take to copy it to a uSD, that should give you an idea of how long it would take.
    How is the uSD card mounted? (Is it via USB or 'internal') If it's via USB some computers will 'reset' the card if other USB devices are inserted/removed whilst activity is in progress.
    What brand of uSD card are you using?
    Mark

    Comment


    • #3
      Hi Mark,

      thanks, the card I bought was a "no name" type badged by the seller (a company here in the UK called Maplin).
      I am using a USB card reader/writer, I will beware of inserting or removing any USB devices while writing.

      Is there a limit to the card size? will you device use the full 32Gbytes or does it just write what it needs?

      regards
      Philip

      Comment


      • #4
        Goldelox can only access the first 4Gbytes, but you can use a 32Gbyte card (which, I guess, one day, will be the smallest available )
        Mark

        Comment


        • #5
          Hi,
          I am still having problems getting started with using a memory card in my display module. I have now bought the recommended SanDisk card (4GB) and I have loaded the example Cool Gauge program.
          The first time I pressed Compile and Download it offered to copy files to a disk, I selected my uSD card which was plugged into the slot in my computer but something went wrong and the card is still a blank, windows formatted unit.
          Now subsequent compiles just seem to download the program to the display module but there is no attempt to write the uSD card.

          How do I get Workshop to load the files onto the card? It's almost as if it thinks it has done it and so wont attempt to do it again!!

          Philip

          Comment


          • #6
            OK, I have just found the Shift F9 feature to force a re-load of the uSD, why that is clearly labelled I don't know but whatever!!!
            So it pops up the box saying "Copy C8XN18~H.gci to selected drive" I choose 'I' which is mu uSD card and the dialog box says "RAW Drive" but then when I click OK it comes back with Rawcopy dialog box saying "Invalid parameter list".
            This is just the Cool Gauge demo program, I haven't changed it in any way so any suggestions about what has gone wrong?
            I'm on Windows 7 64-bit service pack 1 if that is at all relevant
            PhilipJ

            Comment


            • #7
              OK, I have now solved my problem. I was working on a NAS drive and this was somehow corrupting the path so that RAW write wouldn't work. Copying the project onto a local drive has now worked.

              PhilipJ

              Comment


              • #8
                Can you show me what the path to the files on your NAS volume would have looked like?
                Mark

                Comment


                • #9
                  Sure it was:

                  Z:\My Downloads\4D Systems\Workshop 4\Visi Examples\G3002\...

                  I moved it to:

                  E:\4D projects\CoolGauge\...

                  and everything was fine.

                  Philip

                  Comment


                  • #10
                    Ah right, now that I test this I realize I should have spotted this immediately

                    This is a Windows 'Feature'

                    When you run a program as administrator, which is what RawCopy must run as to enable it to write to a uSD card in RAW mode, you effectively log off and log back on as Administrator, hence the administrator does not have access to the Z drive (or indeed any drive that has been 'mapped' by your 'standard' user).

                    RawCopy produces the "Invalid parameter list" message because it can't find the file specified, and since that file must have been created by Workshop only a few moments ago, it assumes that somehow the parameter list passed to it is invalid.

                    For a totally indecipherable explanation of the issue look here http://support.microsoft.com/?kbid=937624

                    For various other peoples explanations, help, venting, etc. google 'network drives administrator'

                    This guy makes a registry change suggestion to fix the issue, I have not tested it, so I don't know if it works. http://www.winhelponline.com/blog/ma...ompt-in-vista/
                    Mark

                    Comment


                    • #11
                      Hey Mark,

                      good find :-)
                      I fixed the problem by moving the project onto a local drive so I don't really need the registry fix.
                      Now that we know, it's easy just to say not to work on a "mapped" drive.

                      Kind regards
                      Philip

                      Comment


                      • #12
                        Oh, I forgot to say in that last reply.
                        Is it possible to rename this thread to something appropriate like "Can't use Mapped Drive" so anyone else who has the problem will find it easily?

                        Philip

                        Comment

                        Working...
                        X