Announcement

Collapse
No announcement yet.

Default Fonts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Default Fonts

    Hi !

    Just updated my code to support the new serial protocol . To be honest, it only took a couple hours. almost painless the new protocol is an improvement. a much cleaner design compared to the old implementation . Question : Is there only (1) Default Font Size ?? I could scale the fonts but to large for my app. Any thoughts ?

    Thanks

    Dwight

    Attached pics (li-ion battery charger) Attached files

  • #2


    Have a look at app note 4D-AN-G5001

    http://www.4dsystems.com.au/appnotes/
    Mark

    Comment


    • #3


      Was admiring the way you mounted the display to the panel. What are you using to "glue" the metal supports to the panel (looks white in color)?

      Comment


      • #4


        surface finish and reflection from camera... 6061 no glue

        Comment


        • #5


          ESPSupport,

          Couple thoughts on the external fonts...

          a 9 char string write using 12pt Lucida Console takes 27ms for the ACK to be received. Is this slow ?

          Fonts Terminal 12, Lucida Console 13 & 14 are corrupt.

          You must reformat the SD Card every time you change the desired font(s).

          OLED displays look great

          thanks

          Dwight

          Comment


          • #6


            a 9 char string write using 12pt Lucida Console takes 27ms for the ACK to be received. Is this slow ?
            That sounds about normal.

            Fonts Terminal 12, Lucida Console 13 & 14 are corrupt.
            Did you create them as per the app note? (just asking before I try it myself)

            You must reformat the SD Card every time you change the desired font(s).
            Actually you don't need to format the SD card at all, the app note is wrong in that regard.
            Mark

            Comment


            • #7


              One more item..

              Set Sector Address does not function correctly with displaying images. You must use Set Sector Byte.

              Dwight

              Comment


              • #8


                Are you sure?

                Can you give a simple example using sector and bytes?
                Mark

                Comment

                Working...
                X