Announcement

Collapse
No announcement yet.

no displaying µOLED 96-G2

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • no displaying µOLED 96-G2

    Hello again Forum,

    I have the following problem: My display worked properly until yesterday, when I implemented it in my device (I had a "reduced" device to check the performance before). I'm not sure what has happend but now the display won't display anything. I tried the SPE load from 4D workshop and it tells me no errors (but doesn't display the splash screen). Also the device is identified correctly in he COMMs tab. But the high voltage regulator (which supplies the power for the display I think) is getting very hot. In addition when I connect the display to my "reduced device" I think there is too much current floating (0,20A) regarding that the display is black.

    I would be very happy if there are any responses about what could be the fault here.
    Is it possible that I destroyed an electronical element and which one could it be?

    Greetings, lh

  • #2
    Hi lh,

    What do you mean by a "reduced" device? If you connect the display to the PC using a 4D programming cable/adaptor alone, does the part you mentioned get hot? I presume that you are referring to U3.
    Yes, it seems that the OLED high voltage circuit was the only damaged part. The processor is still working though, since you mentioned that Worskhop detects the module correctly.

    Regards.
    Doff

    Comment


    • #3
      Hello,

      the "reduced" device is the microcontroller board I used to control the display and other features. The "not reduced" device contains an additional board with some fixed voltage regulators (among others) on it.
      Well yes the part gets hot even if I only use the programming cable. I guess it is U3 by comparing with datasheets but there are no signs on the display board besides the parts. I circled it blue on the picture.

      Well then I probably change that part and try if it works again.
      Thanks.

      lh
      Attached Files

      Comment


      • #4
        Well, I changed that part circled above. It's not getting hot anymore, but the display is still dark. Maybe there's something more damaged...!?
        And now I have a similar problem with a second display of the same kind. The regulator U3 is getting very hot, but this display still displays stuff...

        Comment


        • rcbandwidth
          rcbandwidth commented
          Editing a comment
          Hi: If you could provide a detailed wiring diagram it would make it a bit easier to provide some help,please include some photos also.

          Regards
          Bob

      • #5
        Is what you are displaying mostly white and bright?

        If so you shouldn't do that, OLEDs aren't designed for that sort of thing.
        Mark

        Comment


        • #6
          Hi,

          so I think the cause for my troubles was some short circuit I produed while testing my device, which destroyed my µController and some part of the display board...
          The attached wiring diagram is the best I can provide for the display board, it's from the datasheet.

          Troubleshooting:
          1. display: Situation: U3 getting hot, display black, recognized in workshop. U3 changed (new device: FAN5333B(SX) as labelled in the datasheet wiring diagram), U3 not getting hot, display still black.
          2. display: Situation: U3 getting hot, display still displaying, recognized in workshop. U3 changed (see above), U3 not getting hot, display black, still recognized in workshop. changing U3 back to original part, its getting hot again, display is displaying again.
          My guess: It's another part that is damaged and causing U3 to get hot and the FAN5333B is not the right part to replace U3.
          Any suggestions?

          @ Mark: the background color of my display is black, red or blue with white text on it. Do you think that's too bright? Unfortunately I cannot send a picture as example at the moment.

          Regards, lh
          Attached Files

          Comment


          • #7
            Our hardware guys is having a couple of days off (hmm, it's the weekend, right? ), so I'm going to try and help out with some comments that might not be 100% accurate.

            Not all of these displays used the FAN5333B, Check the markings on the chip you removed to see what that chip was, also check the revision number on the board, so we can be sure.

            ​U3 can get hot if the display is 'too bright'. It can also get hot (and ultimately destroy it) if VHI has become disconnected from the display.

            A picture would help, but usually if you see the display 'smearing' it's a sign it is too bright.
            Mark

            Comment


            • #8
              Hi: Because of your Black display I feel that perhaps the RES OLED line is not going High,This enables the output voltage from U3.Measure with DVM to confirm,also what you have connected external to the display seems to be causing this,please sketchup everything you have connected to the display,without this info it will be difficult to remotely troubleshoot your issue.

              Regards
              Bob

              Comment


              • #9
                Hello,

                so first info: hardware revision of the second display is 4.02 and revision of the first display (older) is probably rev 2 (if I see it correctly).
                The label on the U3 part reads like PHOI, but with internet research I couldn't identify that.
                The attached wiring diagram is the "reduced" device I mentioned before. Could a short circuit somewhere cause trouble for the display?
                Really need help how to repair if possible, third display has same problem now like second display, the current causing U3 to get hot (I guess) is about 200 mA, in correct working condition it was about 20 or 30 mA.
                It's really not easy to relate the parts from the wiring diagram to the parts on the display board, because of the missing labels... But I try to measure some voltages and hope to match them correctly.

                I appreciate your help very much!
                LH
                Attached Files

                Comment


                • #10
                  VHI only 5V with the dark display (no 1), VHI 15V with the displaying display (no 2).
                  RES OLED Line on 3,3V with both displays.
                  Displaying display has some "noise" on D2/L1/U3-1, which I'm not able to measure with the black display.

                  Note: I really don't think that my displaying stuff is too bright... Never saw any smearing.
                  Gotta go for today, hope the data helps you troubleshooting.

                  Thanks so much.

                  Comment


                  • #11
                    Hello littlehedgehog

                    I am quite surprised to hear what you have been posting, as the uOLED-96-G2's are normally very stable display modules and we have very little grief with them at all.

                    It is just very uncommon to hear of failures like this, whether user induced or from self failure somehow... however...
                    so I think the cause for my troubles was some short circuit I produced while testing my device
                    That would explain a few things.
                    To be honest, if you have shorted the module, then you are going to be running around for a while to find out what exactly has failed. Just because the OLED high voltage driver is getting hot, doesn't mean it is the sole cause of the problem. The caps could have been overvolted and therefore not doing their 'thing' anymore, causing the driver to run 'rougher' and cause heat etc. If the processor has inflicted any damage then it could be doing any guess of things. Very hard to know what has happened.

                    Depending on the age of the module, some of the high voltage drivers on some models were the FAN chips, while some were TPS chips. It all depends what revision of the hardware you are dealing with exactly.

                    You are best to put it aside and purchase a replacement. Just be careful when connecting it to your application circuit that you dont short the display modules and make sure each of the connections you make is within spec. If you do this, then the display modules should run stable for a long time.

                    Regards
                    James

                    Comment


                    • #12
                      Thanks for your reply James, but to be honest, it wasn't the answer I was looking for...
                      Could you tell me what kind of voltage drivers is used on the board with rev 4.02?

                      Comment


                      • #13
                        Revision 4.02 Schematic attached for your reference.

                        What kind of answer were you looking for?

                        Did you want us to look into the Datasheets of the components or something to help you figure out what could have happened to your display? Bit hard to be honest since we were not there to experience what happened...

                        Looking at the internals of the FAN5333B, if L1 was not there, then the output would likely be 0V. Since you have 5V there, then it seems 5V is passing from L1, however the FAN you put on there doesn't seem to be oscillating and Boosting the output to 15V. So my guess is the FAN5333B is the problem, but if you have replaced that, then its hard to know.
                        If the Goldelox is dead, then RES_OLED could be off, which means the FAN5333B would be off, which could mean the output could possibly be 5V...

                        Is the Goldelox crystal oscillating?
                        Can you program the PmmC or Application? Pretty sure you said you could, but not 100% sure as to which display we are talking about specifically as you are referring to a few.

                        Regards
                        Attached Files
                        James

                        Comment


                        • #14
                          I'm sorry James for my perhaps a little bit rude last reply and thank you very much for the attached schematic.

                          So to bring you (and others) up to date:
                          1. Display: hw revison 2, U3 replaced with FAN5333B (don't know if this was the right part for this revision), no oscillations from U3, oscillations from crystal, workshop SPE load gives no errors, no displaying, RES OLED 3.3V, Ref U1 (Pin 3) 2.6V, VHI 5V (perhaps we can forget this one an concentate on the other two)
                          2. and 3. Display: hw rev 4.02, oscillations from U3, oscillations from crystal, U3 (TPS as I see in the Rev 4.02 Schematic) getting hot, current flow 200mA, gets recognized in 4D workshop and I can change the splash screen with SPE load, displaying text works, RES OLED 3.3V, Ref U1 (Pin 3) 2.6V, VHI 15V

                          So to me it seems that everything I could check seems ok... or do I miss something?

                          So I try to replace U3 with the TPS tomorrow and see if it changed anything...

                          thanks so much!
                          regards

                          Comment


                          • #15
                            Well, the replacement with the TPS seemed to be the right decision. Can't check the current right now but it's not getting hot anymore.
                            So if I had had the right datasheet revision in the first place I would have spared you all the trouble

                            Edit:
                            Current is ok as well (about 30mA).

                            But... still don't know the cause of this troubles. But I guess that's nothing you could help me with by distance :-D
                            Last edited by littlehedgehog; 26th June 2014, 02:19 AM.

                            Comment

                            Working...
                            X