Announcement

Collapse
No announcement yet.

Raspberry Pi Scope cunundrum

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Raspberry Pi Scope cunundrum

    Greetings:
    ​ I have been playing with a 4D System display and a raspberry Pi for a while now, but now i have a real project to accomplish. By now all de buttons, Forms and LED´s have worked superb. But now I have to plot a three phase graph. So I used the scope, as I have seen it can deal with four traces, and everything was fine. But when I started sending the simulated data it did not plot a sine wave in any trace, as I was expecting. Instead it just plotted three different horizontal lines that change with the value sent from the Pi. I started to try to fix it by changing the value at which it refresh, no result, then I changed the Xmag value, achieving to graph one value and then again the horizontal line in the value sent, for example supposing I have a one trace plot. If I first send a 50, it will plot a line from cero to 50 If then I send a 25, it will plot a horizontal line in 50 and then one to the 25 if now again I send a value of 30 then it will erase the plotted data draw a horizontal line in the 25 and a line to the 30, changing the Xmag value changes the slope of the line. It seems like It is nott saving the other values. I hope someone could help me with this problem.​
    Regards

  • #2
    Hi MrEEPBppt,

    Is it possible to upload your project file so we can replicate your problem here?

    Regards.

    Comment


    • #3
      Shure, I added all the files I think are needed, There used to be a video in Form(0), but in my search for the scope to work I started to remove things. I don´t know if the raspberry pi C code is needed because it behaves the same with my PC. Thanks for your fast answer
      Attached Files

      Comment


      • #4
        I uploaded a video in youtube showing the problem

        https://www.youtube.com/watch?v=ZCTx...ature=youtu.be

        Comment


        • #5
          Hi MrEEPBppt,

          You said on your first post that you need to plot 3 phased graph on the scope.
          On your scope you set it to 4 traces. Have you tried 3?
          If you have 3 traces scope the pattern for updating the traces value is this:

          Trace 1 ->> 50
          Trace 2 ->> 25
          Trace 3 ->> 30

          after sending that values in sequence, scope will update after 30.
          If you send again another 3 values. It will start again in Trace 1 and so on.

          Reagards.

          Comment


          • #6
            Yes I have tried with three, four and one, with the same result. In fact in the code I send the data per fase one after another, in that way you are able to see how three horizontal diferent lines go up and down the screen.

            Comment


            • #7
              Hi MrEEPBppt,

              I've seen on your video that you are sending a file to scope. Is that the hex file sample which is included in Workshop installer? And it seems that the XMAG properties is set a large value.
              Coz we tried your app project here and send a value to the scope, seems no problem.

              Regards.
              Last edited by Abed; 23rd July 2014, 10:37 AM.

              Comment


              • #8
                Yes that file was he square wave file in the single trace scope example, but the result with the other files is very similar. Is there a firmware actualization for the display?

                Comment

                Working...
                X