Announcement

Collapse
No announcement yet.

Display not starting when powered through Raspberry Pi shield.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Display not starting when powered through Raspberry Pi shield.

    I've been using the uLCD-43 with my Mac and have got everything to work through the uUSB-PA5.

    I've now moved my code to the Raspberry Pi and I'm getting all kinds of strange things happening. When I plug in the display to the Pi Display Module then it never displays the initial screen, it just stays blank. Sometimes my program will run and sometimes it won't. It seems that it has problems doing a FileMount or won't do a LoadImageControl. Other times it is absolutely fine.

    If I plug just the 5V and Gnd then the display will power up properly through the Pi. If I plug in either the Rx or Tx then it won't display the start screen.

    I've tried as many different power supplies as I own 5V 1A and 5V 2.1A.

    I've measured 4.84V going into the display. When it is powered from the Mac it measures 5V. Could this be the reason? How sensitive is the display?

    I think the hardware is working although it could still be the power supply. My feeling it is something that the serial port is doing.

    Any suggestions will be very welcome.

  • #2


    4.84v should be adequate, although why you are starting that low should be investigated.

    Pi serial, as I understand it is 3.3v ttl, so it should be able to be directly connected to the display.

    If connecting the Pi's RX to the Displays TX stops the display initializing then there is something very wrong.

    If connecting the Pi's TX to the Displays RX stops the display initializing then you need to check what the Pi is sending. There have been reports of the Pi sending spurious start bits which causes the display to 'see' 0xFF being sent.

    Hopefully someone with more Pi experience will be able to post more
    Mark

    Comment


    • #3


      I found the problem. It was that the Raspberry Pi needs to be rebooted each and every time I run my code. Thanks.

      Comment

      Working...
      X